Pending Approval


Recommended Posts


We have an office network with one server that has an open port to the internet.

I'm trying to share folders with external partners by logging into the our server, using the browser, and generating links there.

What happens often, but not always, is that I get the message to approve the peer on the server, but
when it's approved, little else happens. The peer is listed as 'Disconnected', I can not click it, unlike other
disconnected peers, and the number of peers (total) does not include the peer.

Our partner says that the folder still claims to be 'Pending Approval'.

The folder has 'Use tracker server' and 'Use relay server when required' checked on our server.
It's using sync 2.2.5, because 2.3 just crashes, as I've tried to convey here: 

The external partner of course rushes to suggest other technologies, and I find it very
hard to keep pushing to use Bittorrent Sync, (which I very much would like to).

Please help.

Link to comment
Share on other sites

steinbitglis, that you received request to approve indicates that peers were actually able to connect - either directly or via relay, though after you've approved of it, the total number of peers shall increase by 1. 

So apart from standard "some ports are not opened" the problem might be in :
- time difference - don't you see it in Sync UI? 

- it may take a while for your approval to be delivered, especially on slow remote networks. Let the partner refresh his Sync. 

- try disabling request for approval when sharing the link.

If still no luck, can you please send me the log from your machine? At least from yours, as I think that'll be troublesome to get it from the partner? Log is in the storage.

Link to comment
Share on other sites

  • 11 months later...

I'm having the same issue.  I set up a folder on one Mac (running macOS Sierra - latest version), pasted the link code into the Sync app on the other and it sent an approval request. I approved it on the first Mac but it claims no peers online and the other Mac still says 'Pending approval'. How do I fix this?


Link to comment
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.