Can No Longer Select / View Folders on External SD Card


Recommended Posts

Hey Guys - 

I use BTSync (Pro) to synchronize many folders between multiple devies - one of which is my Nvidia Shield Tablet which runs Lollipop 5.1.1.  When first moving to 5.1.1 a few months ago, I rooted it and added a 64gb SD card. I then edited "/etc/permissions/platform.xml" to add the  "WRITE_EXTERNAL_STORAGE" string therefore providing all apps with full write to the SD card.  I installed BTsync, set up my options, and linked 4-5 folders to various folders on the SD card without issue.  Besides BTSync, I use FolderMount to create symlinks on my internal SD so that I may store all my large games / apps externally.  Today, I renamed a folder on my PC so had to set up the pair again.

The Issue

When in BTSync in Android, I choose to link the folder, but could only select a folder from the internal SD - not the external one as before!  When I go to select the folder, it asks if I want to use on on the Phone Storage or SD Card, but either I pick show the same thing: a screen with "Recent" as the only choice.  From that screen, I can hide / unhide the internal SD, but see no reference to the external one.  There are no errors, I just can't see / browse to it!

I am sure this is due to a BTSync update from the past few months as I haven't changed the OS or anything else.  All other applications still have full access to the external SD, too.

How may I get the external SD to show as an option in this newest version of BTSync?  If it makes a difference, I still have the default folder path in Advanced Options set to "/storage/sdcard1" (which I believe is the external one and sdcard0 is internal) and Simple Mode disabled yet when I try to even create a new folder from the app; I can't browse to the external SD card either.  

Please help - Thanks!

Link to comment
Share on other sites


I think in your case the problem is that Sync didn't receive your sd card as an available storage. So make sure you use Sync 2.3.4, and do the following:
open "Contact support" in E-mail field, instead of your mail, type SNC.DBG.SD, hit "Send" (envelope icon). At the bottom of the screen you'll see the list of available storages. If sd card is not there, in E-mail files type SNC.DBG.SD.ENABLE . See if it helps

If not, please write to support, via this webform, mention this forum topic and provide a few screenshots, or even better a screen record, to illustrate what you actually see. Thank you! 

P.S All Pro users are welcome to write to support directly to get priority help, cause Forum is more intended for community help. 

Link to comment
Share on other sites

  • 4 years later...

Did you ever figure this out? I'm having a similar issue. Can't choose SD card for anything. Tried the debug commands, no luck. Also filled out the "submit a request" form with screenshots and videos, no reply for 3 weeks now. When I try to grant permissions to the SD card, the box never pops up to choose the root of the sd card.

Link to comment
Share on other sites

  • 2 weeks later...

Today I tried to use the android app and Windows 10, folders sync correctly, however, sending files from PC to phone says I do not have permissions to access the usual location in the SD card.

I sent to the default folder and it worked, but then it was quite complicated to send it to the card. Hope this is fixed soon, thanks!

Link to comment
Share on other sites

  • 4 months later...

The same issue as in above post. Sync between W10 and external usb HD on android tv box. Folders sync ok. But when I try to send a separate file from Win10 to Android, I can successfully save only to internal storage or inside the folder that is already been synced (on external HD). 

Link to comment
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.