RomanZ

Latest Desktop build 2.3.3

Recommended Posts

Dear community,

Sync 2.3.3 is now available. You can get it via direct links below, via official download page or via "Check now" button. Build is also available via auto-update.

Direct Download Links:

A list of what's new, improved, changed, and fixed in this version is available in the change log.

Latest Android build is now also available via direct link: 2.3.4 APK
Latest Raspberry Pi package is available via direct link: 2.3.3 DEB

Known issues and peculiarities:
- Linux users please note: starting from 2.3.0, Sync now creates and uses storage folder (.sync folder) in current directory, not next to binary

Share this post


Link to post
Share on other sites

Win64  Pro user , i install and tell to keep original configuration during installation (Wizard ask something about that , can't remember the exact word)

- Updating create a  new device, that was obviously  unlinked from other devices

- I lost all folder configuration, then i link this "new"device to other device and have to reinsert all folder at hand because new folder where created:

Original name of folder was "Folder"

New synch folder is "Folder1"

Folder not in BTSynch default folder , idem have to be reattached at "hand".


Seems to be a bad experience (or i done something wrong, like missing to tell to keep original configration?),  i have another Win64 machine , i could retry the update but i just wait too much folder name to update 

 

Share this post


Link to post
Share on other sites

@antimojv That's a bad experience indeed. From your description it looks like Sync is taking completely different storage folder now. Could you please check

1) that Sync is running under your user account

2) send me the treeview of what you have in %appdata%\BitTorrent Sync (you can use "tree /F > treeview.txt" command to get it dumped into text file)

Share this post


Link to post
Share on other sites

Hi,

I can confirm some major problems with this pushed update.

OSX 10.11.3

About half of around 100 Folders (standard and advanced) where recreated in default sync location with (1) added. 

All custom folder location are lost.

After reconnection the original folders sync stalls with all files shown as "to download".

 

How can I help to fix this?

 

Share this post


Link to post
Share on other sites

No, definitively a lot of "classic" folders where affected.

Switched on debug logs right now.

Some folders show 0kb size in Sync even if they contain files.

All other peers are still on 2.3.2

Share this post


Link to post
Share on other sites

@mzweck It looks like we've found the root cause. It happens if update is shutting down Sync before it finished to load all the folders. We'll include the fix into next build of course, although the bad news is that we can't fix it in already existing builds and you'll have to remove duplicated folders / readd missing ones manually. I apologize for inconvenience.

@gabled-bravado-dell Not sure I fully understand what happens. Short video, please?

Share this post


Link to post
Share on other sites

Ok thank yo for the fix.

In case you still  need info

1) Sync is running as a service now (i check to run as a service during installation)

2) Please tell me the tree info file

Another thing is that now with new web interface if i click on a folder i could not open it in Explorer

Anyway i did not have many folder  :)!

Thank you for fast fix


 

 

 

 

Share this post


Link to post
Share on other sites

@ms2oo8 The issue was that the upgrade popped up before Sync managed to load all folders. The bad news about it is that it only will be fixed in 2.3.4, so this particular issue won't appear anymore while upgrading from 2.3.4 to something else.

If you want to be on a safe side - you can always back up your storage folder prior to upgrade.

Share this post


Link to post
Share on other sites
On 26/2/2016 at 3:48 AM, RomanZ said:

@mzweck It looks like we've found the root cause. It happens if update is shutting down Sync before it finished to load all the folders. We'll include the fix into next build of course, although the bad news is that we can't fix it in already existing builds and you'll have to remove duplicated folders / readd missing ones manually. I apologize for inconvenience.

Is there anything that can be done in the mean time? I lost all my sync folder locations in Linux sometime last week, and just now, after an OS X update that after it finished, logged in for a few seconds and then quit back to the login screen, I lost all my sync folder locations in OS X. I have dozens of sync locations and really consider btsync unusable until some fix is released. I tried also to downgrade to 2.3.2, 2.3.1, and 2.2.7 on both OS X and Linux without success.

Share this post


Link to post
Share on other sites

argos, as RomanZ mentioned; "the bad news is that we can't fix it in already existing builds and you'll have to remove duplicated folders / readd missing ones manually "

Share this post


Link to post
Share on other sites

Thanks GreatMarko. So there's nothing I can do myself? There's the .syncUser* folder and perhaps some other files that point to it. if there's any manual editing I can do to, that'd be ok. I'm just afraid of it happening again; once before many months ago it happened as well and I'm just afraid that'll happen again.

Share this post


Link to post
Share on other sites

@argos You can backup your storage folder (one where you've found .syncuser<timestamp>), although it is not a good measure as if you want to restore it - it will also roll back whole your DB. We are preparing 2.3.4 build which has this issue fixed.

Share this post


Link to post
Share on other sites

RomanZ, Hope the 2.3.4 comes out soon. On OS X I have only one .syncUser folder though I couldn't figure out how to, if possible, to get btsync to use that, and on Linux, it creates a second one. Hopefully both cases get fixed with the update. In the future I certainly will backup before updates.

Edited by argos

Share this post


Link to post
Share on other sites

I installed of 2.3.3 on 2 PCs today, the program did not show up in the program list nor did it put an icon on the desktop as the option said it would.

I was logged in as a standard user on both. I logged in as an admin and ran the install, then logged into the standard account and reinstalled, that time it took. Anyone else seen this?

 

Share this post


Link to post
Share on other sites

@patoka Could you please check next folders for presence of crash dumps (*.dmp files, with timestamp approx. when you started Sync):

  • C:\Users\<user_name>\Roaming\Bittorrent Sync
  • C:\Users\<user_name>\Local\Microsoft\Windows\WER\ReportArchive

Share this post


Link to post
Share on other sites

After a week using 2.3.3 (jumped from 2.2.7), this is what I think:

  1. Love the new service install. Hate that you cannot install as SYSTEM (I mean, you can, but you have to stop service, change account, move config files to SYSTEM profile and start service... much easier if the install took care of that).
  2. I have not been able to configure and access remote GUI access yet. Hopefully options will be added to the UI in the near future to make this possible and also, to allow remote access from any IP via HTTPS.
  3. Memory usage: BAD, very BAD (compared to 2.2.7) I think there is a memory leak somewhere, I have seen cases of 11GB used by the process where before was 4GB (same machine, same number of files)
  4. CPU usage: SO SO. Not as good as 2.2.7. Makes me wonder if there are some debug options active?

 

Share this post


Link to post
Share on other sites
12 hours ago, kamborio said:

After a week using 2.3.3 (jumped from 2.2.7), this is what I think:

Memory usage: BAD, very BAD (compared to 2.2.7) I think there is a memory leak somewhere, I have seen cases of 11GB used by the process where before was 4GB (same machine, same number of files)

 

I agree. Starting from 2.3.x BTS eat a huge amount of resources (both CPU and MEM) on my NAS (Synology DS415+, Intel, 2GB mem).
BTS is managing just about 20 directories.

Please see attached sample/screenshot from my NAS resources analyzer.

 

synmembts.jpg.66ecb6e49308d08984f807c6da

Share this post


Link to post
Share on other sites

@kamborio

  1. When installing, try use the "LOCAL SERVICE" account. Should work fine.
  2. I'm attaching simple sync.conf file. Don't change the filename, just drop it to your storage folder:
    for LOCAL SERVICE account: C:\Windows\ServiceProfiles\LocalService\AppData\Roaming\BitTorrent Sync Service\
    for SYSTEM account: C:\Windows\system32\config\systemprofile\AppData\Roaming\BitTorrent Sync Service\
    Then restart the service. It'll listen to all available interfaces. Adding the ,"force_https": true to the config file in "webui" section will also enforce https, although it does not work on windows due to known issue (already fixed, will be available in 2.3.4)
  3. (And 4) Its not a debugging turned on, neither memory leak. I suspect it is bound to new flow of things in Sync core. There was an couple of issues addressed regarding mem and CPU usage in upcoming 2.3.4, although I'll be more than happy to peek into your debug logs to see if this is something we already fixed or that is something new.
     

@carloxp Could you please provide an idea on how many folders and files you have in total added to Sync? Or, at least compare on what was the consumption ifor 2.2.7? Thanks!

sync.conf

Share this post


Link to post
Share on other sites
1 hour ago, RomanZ said:
  1.  

@carloxp Could you please provide an idea on how many folders and files you have in total added to Sync? Or, at least compare on what was the consumption ifor 2.2.7? Thanks!

 

Version 2.3.2 destroyed my folders list both on PC's and NAS. So, I reinstalled 2.3.3 from scratch on NAS.
It's difficult also remember what was the CPU/MEM consuption with 2.2.7. I can only say that I never noted abnormal usage on the NAS.

Currently I have 23 directories shared on the Synology NAS and only 1 PC linked. Difficult to say how many files. Maybe ~100,000. If necessary, I can count by sumarizing folder by folder. Just ask.

BTS running:

bts-on.jpg.454504475c7a35ad6785df324fc44

BTS not running:

bts-off.jpg.27cff300ed5e042eb1e0c47a19ed

My Synology NAS has 2GB or RAM.

Currently installed bittorrentsync_avoton_2.3.3-1

 

Share this post


Link to post
Share on other sites

@carloxp The issue with all folders disappearing in 2.3.2 and 2.3.3 was already addressed in 2.3.4 (which is on the way).
For the amount of files - I'm asking as amount of memory consumed by Sync is proportional to amount of files and folders it manages. It takes around 1.5 Kb of memory per file. So, the 100K of files and folders will force Sync to allocate around 150Mb of memory. So this info can give a hint if memory consumption is adequate or something is going wrong.

Share this post


Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.