Freenas - Freenas (and some macs) sync issues


Recommended Posts

Hi all,

 

I'm having major issues trying to sync files on FreeNAS. 

My setup is a macmini and a freenas box located on the same network central London.

Also a macmini and a freenas box located in on the same network in south London.

All machines run BTSync 2.3.1.

Both networks have fixed IPs.

Each instance of BTSync has a different port number and these ports are allowed through the firewall. All instances of btsync have the other machines as defined hosts.

Just in case. and to remove any issues I run a script on the FreeNAS to make sure all file permissions are open to everybody. This will not affect modification dates.

There's a lot of files to sync here; 575G comprising of 743 directories and sub-directories, 18153 files.  

Due to speed, space, data management and other issues, I need to use the FreeNAS raid I have instead of the macs, which will soon be needed for something else.
 

I find that on the FreeNAS boxes I'm consistently missing odd files here and there.  Only this morning I had to manually compare the mac and freenas files and folders; I found one folder on the freenas with over 9gb of files missing, although the files were sitting on the Mac on the same network. The files had been syncing for weeks.

The worst thing is that updated files are not being overwritten. So you update a file on the Freenas box  it can just stay there and is not synced with the other machines. It's a bit random!

Now I've been running BTSync since 1.2. so have a fair idea about it, but something is wrong here and I can't get to the bottom of it.

I've tried lowing the folder rescan times, Leaving them as they are. It seems that Sync broken on FreeNAS. 

 

Is it?

 

 

Any ides here would be really welcomed.

Cheers

 

Bill

 

Link to post
Share on other sites

Another update. This is here so the support team can reference this thread

As a reminder, I’m running BTSync 2.3.3 on  Freenas 9.3.1 and a Mac OSX 10.11 on the same internal network. I have the same setup on a second location. Both sets connected over internet. I'm having issues with files not syncing between the machines.

 

I upgraded to 2.3.3 on all devices , created new freenas plugins and jails,  started new the btsync and re-synced everything yesterday evening. 

The initial sync looked good and it seemed that most things were syncing. The speed was ok until the last few files where the speed went from MB/s to b/s.

This morning not all files are copying over. New or updated files on the FREENAS seem not to make it to other systems.

 

FOR SUPPORT

 

Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.