Recommended Posts

I've seen several threads here, but wanted to add mine.  I've been using Sync on 5.1 and previous on several rooted devices with the ExtSD write fix patch to sync my music and pictures.  It's been great.  But lets just focus on the music since it’s been a static set of files for quite some time.  826 files, 3.7gb.


I've recently upgraded my LG G4 to Marshmallow and after the fact I find there is apparently no ExtSD write fix for 6.0.  I don't expect that to stay the case, my LGOG e970 with NitrogenOS MM 6.0 Rom can write to ExtSD as always.


Pretty sure I was running Sync 2.3.4 at this time.


I've been trying to use Sync on my G4 periodically since the upgrade with no luck at all.  After the upgrade the ExtSD path had changed so all of my sync folders were broken.  At first I tried to remove them and re-add them one by one with the new SAF "ON SD CARD".  That was extremely slow and not very responsive,  Frequently it wouldn't accept clicking "Add folder", it would just sit there like nothing happened.  This was without deleting the ".Sync" folder.  So I stopped trying to add the rest of my folders again and just let it sit for a day or so to index.  


Updated to Sync 2.3.5 which claimed fixed getting stuck indexing on SD Card


Folders continued to index.  I think it was making progress.  The file count in details was increasing, across a day and a half I index 250ish files....  That's insanely slow.  

Clears data from Sync and started over with a clean folder.  Sync still says indexing, transfers have started, details reports size 1gb.  But it seemed to be stuck there.  I chose to “Exit” sync from menus, and it appeared to shut down properly.


After restarting Sync, it listed “Database Error” next to my folder.  I chose Exit again, then started to work on this post.  I reloaded Sync to get some of the exact working of the buttons and labels and now it back to indexing. The Database error fixed itself?  And suddenly the folder size is reporting 2gb (427mb synced).  445 Files (101 synced).  It’s seems to me like it’s not even getting/processing the full file list.



I also just tried removing the folder and reconnecting with a folder “ON PHONE” and while the file list seems to download within 10 minutes, the transfer has stalled out at 318mb and reverted to indexing.  Details reports the proper 826 files 3.7gb.

On my other devices the peers listing shows the G4 as offline.  If I cycle wifi on the G4, for a moment it shows on the other devices as online and sending.  The G4 peer list shows receiving, but the folder list still says indexing.  


Before I could actually post this the internal storage has finally decided to work.  Music is has finished transferring to internal storage.

Link to post
Share on other sites
  • 4 weeks later...

Must be part of the beta program.  I remember clicking a link to signup for it, but my version never changed.

There must not have been a beta at the time....  And now I can't find the signup link or the google plus community like the other betas I'm involved with.  I'll keep looking,  I want to update my wife to this build also so I can finally bring her phone to MM and get rid of the Rom Update Available notice.

Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.