[Solved] Run btsync after install from repository on Raspberry Pi


Recommended Posts

I am new to Raspberry Pi and Linux. Currently run Sync on Macs. I am trying to run btsync on a Raspberry Pi 3 using the btsync install from the official repository. I am able to get it installed using apt-get. But after I am having no luck getting the service started. Please help me with what to do after it is installed. 

I tried to run the executable btsync in in /usr/bin subfolder but it does not start and I can't connect to it on port 8888. That port does not show as open in netstat. The configuration screen never comes up. When I run it in terminal it just goes back to a command prompt. How do I start it up properly and what is the best way to make its start on boot.

Thanks in advance for help.

Link to post
Share on other sites
  • 5 months later...
On 3/15/2016 at 0:04 PM, dh250 said:

I figured out how to get btsync started. I also could connect to btsync from within the RAS Pi GUI. So those are resolved. I would appreciate advice on the best way to get it started automatically on boot.

Hi dh250,

I just installed on my raspberry pi and cannot seem to get the service started. can you (or someone else) help explain what you did to get it going after you had your initial trouble? I keep getting an error telling me that No /usr/bin/btsync found running whenever I try to stop/restart the program.


Link to post
Share on other sites


Here are a few things to check and do:
- make sure you have enabled the service (sudo systemctl enable btsync) - see if you get any errors in output
- try to launch the service manually - sudo service btsync start  - also check out for errors 
- if it fails, manually go to /usr/bin/ and launch btsync binary from there (command ./btsync) . I suppose you might get "Segmenation fault". IN this case, please see this post


If nothing helps, then please share any details on errors from the commands above, and on the exact way you installed Sync 

Link to post
Share on other sites


This topic is now archived and is closed to further replies.