Andy+

DSM 6.0 upgrade says Sync not compatible

Recommended Posts

it starts but config is clean (so it has to be?)

and why is  listening  IP is 0.0.0.0

Still does not works when started by the DSM itself. 

nas01.JPG

Edited by kornac

Share this post


Link to post
Share on other sites

@kornac Try do the following: when you SSH to Syno, navigate to "/var/packages/bittorrentsync/scripts" and run "sudo ./start-stop-status start" and let me know the output of you see (ensure that no other versions of Sync are running prior you do it, of course). This is pretty much the same Syno does when you click the "Run" on DSM.

Share this post


Link to post
Share on other sites

@kornac It looks to be an issue in DSM itself. Your admin has no default shell in /etc/passwd. I suggest to edit your /etc/passwd and change the /sbin/nologin to /bin/sh for admin. You'll need root access of course. Let me know if it helps.

Share this post


Link to post
Share on other sites

Hi, I've upgraded to DSM 6 RC and installed the latest btsync .spk.

Doesn't start through package manager and neither when I try to run it from ssh, I get 'segmentation fault'.

Share this post


Link to post
Share on other sites

Hi guys,

I've got the same issue on DSM6 RC, it look like the Admin user account is now disable by default for security reason.

If you renable it Btsync will start.

 

Share this post


Link to post
Share on other sites

Same Issue with DM 6.0 RC and BTSYNC 2.3.3

sudo ./start-stop-status start

Password: 

Starting BitTorrent Sync ...

su: warning: cannot change directory to /var/services/homes/admin: No such file or directory

-sh: line 1: 10638 Segmentation fault      PATH=/usr/local/bittorrentsync/bin:/sbin:/bin:/usr/sbin:/usr/bin:/usr/syno/sbin:/usr/syno/bin:/usr/local/sbin:/usr/local/bin:/var/packages/Java7/target/j2sdk-image/bin:/var/packages/Java7/target/j2sdk-image/jre/bin /usr/local/bittorrentsync/bin/btsync --config /usr/local/bittorrentsync/var/sync.conf

 

Share this post


Link to post
Share on other sites
On 4.03.2016 at 0:20 PM, RomanZ said:

@kornac It looks to be an issue in DSM itself. Your admin has no default shell in /etc/passwd. I suggest to edit your /etc/passwd and change the /sbin/nologin to /bin/sh for admin. You'll need root access of course. Let me know if it helps.

@RomanZ

It helped, but after a reboot synology need to repeat it again change in /etc/passwd.

 

Share this post


Link to post
Share on other sites

@kornac I'm not sure why it happens to your NAS and what would be the policy of Synology towards shells in DSM 6.0. We'll better wait till they provide some stable RC here.

@Peter1968 @JanNLD (and any other who experience segfault): what is your NAS model? Try logging in to SSH and replacing your Sync binary with this one. Let me know if it helps.

@Guik Rather strange. We have it ON on our DSM 6.0. Will update to latest version and see if it is still the same.

Share this post


Link to post
Share on other sites
6 hours ago, RomanZ said:

@Peter1968 @JanNLD (and any other who experience segfault): what is your NAS model? Try logging in to SSH and replacing your Sync binary with this one. Let me know if it helps.

This worked for me on my DS214 with a freshly installed 6.0RC. To make it work with a disabled admin user, I changed the start-stop-status script to run under my default user which also belongs to the administrators group.

Share this post


Link to post
Share on other sites

DS412+ with DSM 6.0-7307
btsync 2.3.5-1

Installed via package manager.
Error: "Failed to run the package service"

 

Haven't tried anything else yet, because I need to re-enable root access first (and have no time to tinker with it currently). 

Share this post


Link to post
Share on other sites

@had-to-reregister @all Actually, there is an issue between DSM 6 and DSM 5. For certain platforms DSM6 require ARMHF build, while DSM5 requires ARMEL build for exactly same platform. We want to avoid making 2 flavors of package for every platform. Therefore all existing packages are being built with target of DSM5 (as DSM6 is still in beta).

If your package does not work well and Sync does not start on DSM6.0 - you'll have to manually replace Sync binary to ARMHF. Binary always stays in "/usr/local/bittorrentsync/bin/btsync" for all Syno devices.

Share this post


Link to post
Share on other sites

Found the solution. Synology wants you to use a defined user for your apps.

The following needs to be changed for the next release of btsync for NAS.

--- postinst	2016-03-18 20:43:19.572117411 +0100
+++ /tmp/postinst	2016-03-18 20:43:10.640752347 +0100
@@ -1,3 +1,13 @@
 #!/bin/sh
 . `dirname $0`/installer
 `basename $0` > $SYNOPKG_TEMP_LOGFILE
+
+synouser --get btsync
+if [ $? -ne 0 ]
+then
+    # create user with random password
+	synouser --add btsync `uuidgen | cut -c-8` 'Bittorrent Sync User' 0 '' ''
+else
+    synouser --modify plex 'Bittorrent Sync User' 0 ''
+fi
+
--- start-stop-status	2016-03-18 20:45:26.515055527 +0100
+++ /tmp/start-stop-status	2016-03-18 20:45:09.832249852 +0100
@@ -14,8 +14,8 @@
 
 start_daemon ()
 {
-    chown -R admin:administrators $INSTALL_DIR/var
-    su - admin -c "umask 000; PATH=${PATH} ${BTSYNC} --config ${CFG_FILE}"
+    chown -R btsync:administrators $INSTALL_DIR/var
+    su - btsync -c "umask 000; PATH=${PATH} ${BTSYNC} --config ${CFG_FILE}"
 }
 
 stop_daemon ()

Oh and need to make sure if it is an upgrade that the BtSync folder needs to change owner as well.

Edited by robingruyters

Share this post


Link to post
Share on other sites

I am running BT Sync on DSM 5.x and trying to do the upgrade on the Synology box to the official DSM 6.0 release.  When I start the upgrade it stops a minute in and states that BT Sync is not compatible with 6.0, and that it must be disabled in order to complete the upgrade.

Is BT Sync compatible with DSM 6.0?

If so, should I just stop the service before the upgrade and then manually start after it finishes?  Or should I do something else?

I am running BT Sync 2.3.5.

Thanks!

Share this post


Link to post
Share on other sites

Well… awesome. I just updated my Synology to DSM 6 and BTS doesn't work?

I'm going to assume that there was someone at BTS, Inc. who was working on this during the DSM beta period but somehow it slipped through anyway.

Share this post


Link to post
Share on other sites

@all

Unfortunately, submitting packages to official stores as well as adopting to new OS depends not only on Bittorrent, but also on Synology. Both are is rather slow procedures as it includes some internal Synology tests.

You can download latest version of Sync for Synology here for manual install, although Sync MAY not start under DSM6 (it depends on your NAS model), as Syno has changed the policy towards ARM / ARMHF builds requirements in DSM6.

Share this post


Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.