Listening port isn't saved on Linux (Raspbian Jessie)


Recommended Posts

After doing a clean installation on my Rpi 2 I realized that the listening port wasn't saved but every other configuration parameter does.

If I manually set it to 45454 (for example) and then I reboot the service a new random port will appear. If I keep restarting the service more and more random ports appear, it never gets fixed.

- Every file in "/var/lib/btsync" has the user btsync as owner.

- My port will only be fixed if I manually set it in "/etc/btsync/config.json"

 

Link to post
Share on other sites

Darius, by default the option for listening port is set to be random:

"listening_port" : 0,

If you comment it by "//" symbols Sync won't random it and you'll be able to set listening port in the WebUI.

//"listening_port" : 0,

Please note that you need to restart Sync service or use SIGTERM signal so it will definitely save settings.

Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.