Android devices not syncing deletions


Recommended Posts

I've just installed V2.3.5 480 on my Sony z5c phone with a clean install of android 6.0 and also on a new Samsung tablet with factory fresh Android 4.4.4 rooted with writable SD card. I've synced some sd card folders on these devices with my existing laptop V2.3.3 296 and Raspery pi always on hdd server with V2.2.7 160.

When I delete files on either of the android devices the deletions are not being picked up by Sync. The deleted files remain in the Sync file list with a blue tick beside them even though the files were deleted a few hours ago. Adding new files and renaming files in the same folder is picked up straight away and propagated to all devices as it should be. Deleting files on the laptop or on the Pi server works almost instantly as it should and is propogated correctly to both Android devices.

Shutting down Sync on either Android device and then restarting Sync causes the file deletions to be detected and then propogated to the other machines.

I've tried with and without auto sleep on but it made no difference. 


Link to post
Share on other sites

nrgbod, probably It happens because of "Selective Sync" and it is by design. If you need open Sync, highlight files and choose "Remove" from the context menu. Then files will be deleted from other peers. Sync has the same behaviour for windows when webui is used and for linux if "Selective Sync" option is activated for the folder.

If "Selective Sync" option is disabled on Linux or Android device Sync should delete files from other peers.

Unfortunately I could reproduce files deletion after restart. In my case files are deleted immediately (when "selective sync" disabled) or just unsynced from the android device (when "selective sync" enabled). You can send us a feedback, include logs and tell which files you deleted on the device so we'll see what happens in the Sync.

Link to post
Share on other sites

Remirus thanks for replying. Selective sync is turned off but both devices are not picking up the file deletions. The Tab picks them up after a restart and then deletes from all machines. The Sony Z5 on Marshmallow doesn't pick up deletions from it's own SD card no matter what I do. The Z5 will only remove the files if I manally select "remove from all devices" for each file in BTSync.

The same folders and machines where syncing fine when the Z5 was on Lollipop and V420 of sync. 

I will send in the logs as soon as I can.

Link to post
Share on other sites
  • 6 months later...

Having eagerly tried every update since April hoping for a fix for the Sony Z5C Marshmallow file deletion bug I have yet again been disappointed. Yesterday I did a fresh install of the latest MM update followed by the latest version of Resilio sync for android v2.4.3 (586) and found that file deletions from my SD card sync folders are still not being picked up.

I restored the phone back to the final version of Lollipop with the same version of Resilio sync and it now works fine again.

Is there anything I can do to fix this bug or am I going to be stuck on Lollipop forever?

Link to post
Share on other sites

As far as I know, in support ticket you also reported the fact that deleted subfolders re-appeared, and that was addressed  - do you still see this issue or is it just deleted folder not propagated until Sync restart? 
If the latter, then this is a new case, and we'd love to see at the logs from v.2.4.3 reproducing it. Thanks 

Link to post
Share on other sites

I have just tried this again, after a full wipe of the sony phone I reflashed the latest version of android MM 6.0.1and reinstalled the latest version of Resilio sync from play store. I linked a rw test folder from my other machines which are all running the latest version of RS without problems.

I then copied a load of files and a subfolder into the test folder of the Sony phone. It picked all the files and the sub folder up and propogated them properly. I then renamed most of the files on the Sony. Sync picked up the renaming as new files and added them to the other machines but it kept the kept the old files with original filenames despite them no longer being on the SD card.

I then started deleting files on the Sony which sync did not pick up. Then I deleted the sub folder containing three files and sync again did not pick it up.

I restarted sync and also tried rebooting the phone but the phantom files and folder remained in the Sony sync list and on all the other machines.

Files deleted or renamed on other devices are picked up correctly by RS on the Sony.

The same test folder was working fine with previous version of Android LP 5.1.1

I had logging running while testing this so I will send it in to support.

Link to post
Share on other sites


This topic is now archived and is closed to further replies.