ecotec

Issues installing offical linux packages on Pi

Recommended Posts

I'm trying to install BTsync on on a Raspberry Pi B+ (Jessie), I followed the instructions on the blog and added the offical linux packages, it installed OK and I ran:

sudo service btsync start

Then checking status seemed to suggest that everything was working OK, however I can't access the gui from another machine on the network to complete setup

I'm using: 192.168.1.100:8888/gui (I've confirmed the pi IP is correct with ifconfig).

It seems I either need to complete an extra step of set up somehow?

Share this post


Link to post
Share on other sites

ecotec, you can edit config file:

/etc/btsync/config.json

There you need to replace 127.0.0.1:8888 by 0.0.0.0:8888, instead of 8888 you can specify another port.

//before place:
        "listen" : "127.0.0.1:8888"
//after replace:
        "listen" : "0.0.0.0:8888"

The current value is set for certain purpose: no one will access WebUI unless you enable it.

Share this post


Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.