[solved] Headless Linux, cannot connect to WebUI

Recommended Posts

I am trying to install the latest version of btsyc on a CentOS 6.5 headless server. I cannot reach the WebUI.

I configured the webui on port 65000. This is confirmed by the command line reply when I start the service:


Webui is listening on

The service itself is configured to run on port 8888.
When I run `lsof -Pnl +M -i4`, I get the following output:

btsync    25687      500    9u  IPv4 536416051      0t0  TCP *:8888 (LISTEN)
btsync    25687      500   10u  IPv4 536416052      0t0  UDP *:8888
btsync    25687      500   13u  IPv4 536416060      0t0  UDP *:3838

Nothing else seems to be listening on 65000. I tried `netstat -tulpn` as well and the results are the same. I added a rule to iptables and `Iptables -L` returns (among others):


> ACCEPT     tcp  --  anywhere             anywhere            state NEW tcp dpt:65000

But to make sure I tried to run it while the iptables service was completely switched off, and I still could not get any different results.

The logfile sows the following:


    [20160521 17:24:25.687] Configuration from file "/home/includes/btsync/btsync.conf" has been applied
    [20160521 17:24:25.690] ZIP: Can't locate [version] in zip, error -100.
    [20160521 17:24:25.692] PLC[0x000000000225a8c0] binding on
    [20160521 17:24:25.692] Socket[0x000000000225a8c0][9] bound listening socket 9 to IP
    [20160521 17:24:25.692] UDP: bound listening socket 10 to IP
    [20160521 17:24:25.694] test sha1: ****************
    [20160521 17:24:25.694] test sha2: ****************
    [20160521 17:24:25.694] test aes: ****************
    [20160521 17:24:25.694] Loading config file version 2.3.7, current version 2.3.7
    [20160521 17:24:25.694] My PeerID: 107408D3698D9BCA3EF7D****************
    [20160521 17:24:25.695] LC: LoadLicenses: there is no pro license
    [20160521 17:24:25.695] loaded history: 0 events
    [20160521 17:24:25.697] setup socket 13 for local peer discovery for success
    [20160521 17:24:25.697] Debug log mask has been set to FFFFFFFF
    [20160521 17:24:25.697] Features mask has been set to 0
    [20160521 17:24:56.835] OpenSSL: Loaded X509 trusted CA from "/etc/pki/tls/certs/ca-bundle.crt"

I tried to run webui on a different port, the result is the same.
I also tried to bind the webui on my server's IP address instead of, same result. Any ideas?


So I started this whole process again with a default config and on port 8888 and now it worked. As a recommendation for people in the future who have such an issue, try to use this command here:

    curl -k http://xxx.xxx.x.xxx:8888/gui -v

to see if the server is running from the server's command line. It should show a quite long bunch of HTML if the server is running properly. If that works, try to amend the config file from there on



Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.