Olotila

My folders disappeared

Recommended Posts

My folders disappeared, I previously had at least two folders. I think I remember my creditentials and sync name right. How do I get the folders back? I tried to get my camera folder back, and that is the only one showing here. I do have a sync folder with NAS, but it does not show here.

I do have the keys to the important NAS folder, can I use them to get back the folders?

When I log into NAS sync gui, the folders are there. I can see the Fingerprint of the device, can that help?

sync.png

syncnas.png

Edited by Olotila

Share this post


Link to post
Share on other sites

First of all, as far as I can see, the NAS has a backup and Encrypted folders? If you have RW key to that folder saved somewhere you can connect to it.

Apparently , Sync on Ohtonkone started with a new storage folder == new settings? Storage folder location is a bit tricky on a linux.  Were you prompted for a new identity right before you noticed folders gone? I suppose you've manually added Camera folder back, right? Any details on what happened to the peer before that ? There shall be something that triggered it. 

Share this post


Link to post
Share on other sites

When I started btsync program and went to localhost:888, it asked creditentials. I gave the same I previously had. I think it asked new ones but I just put the same I had earlier.

I do have the keys.

Share this post


Link to post
Share on other sites

So, you can reconnect the folders. 

Any details on what happened to the peer before that ? There shall be something that triggered it. 

Share this post


Link to post
Share on other sites

Now my camera folder disappeared too. I haven't changed anything. If I reconnect, how can I prevent this from happening again? Will the resync take long this way? My Tähelliset folder is over 1TB.

Share this post


Link to post
Share on other sites

to know how to prevent it, we need to know what's causing it. 
Make sure that you run Sync 2.3.7 on all desktops, and please send debug logs from all peers affected, here's instruction 

Share this post


Link to post
Share on other sites

It works again, and I do not know why. I put the sync.log to Tähelliset/.sync for future problems. Is there some metadata I can backup and restore if this happens again? 

Share this post


Link to post
Share on other sites

why would you put sync.log to Tähelliset/.sync ? This directory only keeps Archive, ID and Ignore and Streams list referring to Tähelliset share.
You can backup the storage folder , but having an encrypted folder in your mech, backup of setting does not guarantee its successful restoring, see the article on restoring the encrypted folder.

Share this post


Link to post
Share on other sites

I guess I missread the guide. I do have debug.txt in folder where my btsync binary is. It only contains the F's and a zero in second line.

I read the article, but I am not sure it is relevant in this situation. I think I have everything in place, all the .sync folders (near btsync binary, Kamaa and Tähelliset) containing what they should (near binary lots of files, in Kamaa and Tähelliset only the things you mention.  I do not want to restore files from encrypted folder, only want it to appear in attached view.

Now the folders have disappeared again. Yesterday I did have Kamaa and Tähelliset. 

I will try to boot my system and try again. Could this be caused somehow by me using zfs? It is the only thing coming to mind but I do not comprehend how it could affect this.

Screenshot from 2016-06-20 21-00-33.png

Share this post


Link to post
Share on other sites

The storage folder - on each platform it will be different - keeps all the settings of Sync, including your folder configs. If these settings are OK and not damaged, and are readable, Sync will load all your folders on start. If not, or if a new storage is created, Sync will  NOT load your folders. So you might want to backup the storage, so that in case the folders disappear again, you can just point sync to backed up storage and get the folders back. Hope it's clear now. 

BUT, this trick may not work because you have an encrypted folder, restoring its connection from back may be tricky.

Share this post


Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.