Helen

Latest Desktop Build 2.4.0

Recommended Posts

Dear community,

Resilio Sync 2.4 is now officially available. You can get it via direct links below or via official download page. Auto-update is not available yet.

UPGRADE
Resilio Sync 2.4 is released with Resilio brand, it is treated by OS as new application and will propose you to migrate all your settings from old BitTorrent Sync app (settings are backed up during migration).
Please carefully read these articles about updating to Resilio Sync and migration of settings.


DOWNGRADE
Resilio Sync will make a backup copy of all your settings prior migration into "sync-v2.3.7-1471003319.backup"-like folder (version and timestamp may vary). If you decide to return to 2.3.*, you'll need to manually copy the content to your storage folder, remove Resilio Sync and be aware of next downgrade drawbacks:

  1. You'll downgrade to "Free" version and you'll have to re-apply license manually
  2. File association with license files *.btskey is broken so you'll need to apply license in BTSync UI
  3. Downgrade is not supported for Selective Sync folders (as all placeholder files are renamed to *.rsl*). If you downgrade and your Sync has Selective Sync folders, your files are going to be deleted on all peers.


Direct Download Links:

A list of what's new, improved, changed, and fixed in this version is available in the change log.

Latest Android build supporting migration to Resilio Sync: Android 2.3.7

Share this post


Link to post
Share on other sites

Installing/Upgrading from b662 to 2.4 Windows x64 (desktop) b666 worked as expected.

Installing/Upgrading from b662 to 2.4 Windows x64 (service) b666 appeared to complete installation, but upon opening my browser to view if the upgrade was successful, it was still showing that build b662 was installed.

I stopped and restarted the service and it still reflected that b662 was the current version. I tried the install again, same result.  

I killed the Sync process from Task Manager, and verified that the service was stopped, I then did the install, opened my browser and it now reflects the successful upgrade to b666.

If stopping the service prior to upgrading is required or recommended, I think that should be stated during the upgrade process.

Share this post


Link to post
Share on other sites

Are there any versioned download links?

Having no version number in the download link, preferably in the filename, makes it impossible to properly package this for various distributions.

Share this post


Link to post
Share on other sites

@rimanek, @YI WANG,
not much difference from RC2, some revealed crashes fixed. See the change log. YI WANG, what exactly details would you like to know? 

@jfreiman,
service shall stop itself when updating. I've just checked and update went correctly and new UI with v2.4.0.666 opened. I wonder what user you had the service 662 running and what user 666 installation was launched. 

@BtbN,
replace 'stable' in the link with '2.4.0'

Share this post


Link to post
Share on other sites

And again not working on Raspberry Pi 1. Last working version from the official repo was 2.3.7 with arch=armhf. Since then the binary didn't work on Pi1 which is a ARMv6+VFP2 ARM variant so it has a hardware floating point unit. Maybe resilio has to take care of this when compiling the binary.

Please fix this... it's really annoying

Thanks

Share this post


Link to post
Share on other sites

@patho,

package has two binaries, and installs the one in accordance with system specs. then apparently your RPi is on arm. wget the arm binary from the first and put it to /usr/bin instead of the rslsync that is currently there. start the service. 

Share this post


Link to post
Share on other sites

Hi,

I try to migrate from 2.3 to 2.4 on my synology DS415+ with DSM 6.0.2, the problem is opendkim and sync 2.4 use the same port 8891 and I can't install sync.

I can't modify the port for opendkim, the DSM no have this option.

I open the support ticket for this problem.

Share this post


Link to post
Share on other sites

So I take it that any share link I distributed using BTSync will not work for someone who just freshly installs the new version??

i never received an email or push notification notifying me of this Big change.

Share this post


Link to post
Share on other sites
On 15 settembre 2016 at 0:24 PM, Dariel said:

Hi,

I try to migrate from 2.3 to 2.4 on my synology DS415+ with DSM 6.0.2, the problem is opendkim and sync 2.4 use the same port 8891 and I can't install sync.

I can't modify the port for opendkim, the DSM no have this option.

I open the support ticket for this problem.

I have the same problem on my DS215j...it ask me insert a password as shown in the attached file

Schermata 2016-09-17 alle 00.58.50.png

Share this post


Link to post
Share on other sites

Hi,

I wanted to upgrade from 2.3.8 to 2.4. 

It says: 2.3.5.: "Support for migration to Resilo Sync added"

Now I'm not sure if the IOS App (2.3.5) can connect to 2.4 ?

Thank you

Peter

 

Share this post


Link to post
Share on other sites

The iOS App can connect to 2.4 Resilio Sync. There will be more info coming about the iOS App and how it will move to Resilio Inc.

Share this post


Link to post
Share on other sites

I followed the instructions in the migration article and did the upgrade from BitTorrent Sync 2.3.8 to Resilio Sync 2.4.0. It seems to have been successful.

The migration article says this:

Quote

Old BitTorrent Sync storage folder at C:\Users\username\AppData\Roaming\BitTorrent Sync will be moved to new storage folder at C:\Users\username\AppData\Roaming\Resilio Sync

But after the installation/migration I have both of those folders, the one called 'BitTorrent Sync' and the one called 'Resilio Sync'. Therefore, it wasn't a "move" that occurred but probably a "copy".

Is it safe for me to delete C:\Users\username\AppData\Roaming\BitTorrent Sync  ?

Share this post


Link to post
Share on other sites

@luca,

No, it's not the same. In your case you need to put the credential you've defined when first installing and running Sync. WebUI on NAS is always protected with login/password. See this article

@pbeng,

Currently, Resilio Sync (v.2.4) is not out for mobiles. But we've released v 2.3.5 (2.3.7 for Android), which have functionality for further migration, when 2.4 is eventually out. Thus "Support for migration to Resilio Sync added" 
 

@eldrin,

Settings are moved.  I suppose that in BitTorrent Sync you have only .pid and Extension dll and log?  You can delete those. Before doing that unregister dll in elevated Command Prompt with command "regsvr32 -u C:\Users\username\AppData\Roaming\BitTorrent Sync\SyncShel.......dll. Reboot machine. 
 

Share this post


Link to post
Share on other sites
5 hours ago, Helen said:

@eldrin,

Settings are moved.  I suppose that in BitTorrent Sync you have only .pid and Extension dll and log?  You can delete those. Before doing that unregister dll in elevated Command Prompt with command "regsvr32 -u C:\Users\username\AppData\Roaming\BitTorrent Sync\SyncShel.......dll. Reboot machine. 
 

This is what is left in 'C:\Users\Username\AppData\Roaming\BitTorrent Sync' after the migration :

BTSync.exe.18479.tmp
ShellExtCM.log
ShellExtensionPath64_1C3.dll
ShellExtensionPath64_11F.dll
ShellExtensionPath64_17A.dll
ShellExtensionPath64_103.dll
ShellExtensionPath64_128.dll
ShellExtensionPath64_230.dll
ShellExtensionPath64_EF.dll
ShellExtIO.log
sync.lng
sync.pid
SyncShellExtension64_64.dll
SyncShellExtension64_68.dll
SyncShellExtension64_70.dll
SyncShellExtension64_76.dll
SyncShellExtension64_83.dll
SyncShellExtension64_93.dll
SyncShellExtension64_A0.dll

Share this post


Link to post
Share on other sites

eldrin, those files were probably left because either a) they are log files which can safely be deleted (i.e. the .log file), or b) they are temporary files (in the case of the .tmp file) and so can be safely deleted, or c) they were in-use by Windows (in the case of the .dll files) at the time you installed Resilio Sync, and so Windows couldn't delete them whilst they were in use.

They should all be safe to delete, but if in doubt, you could always rename the folder to something like C:\Users\Username\AppData\Roaming\BitTorrent Sync-OLD first, reboot your machine, check Sync is running correctly, and if so then delete C:\Users\Username\AppData\Roaming\BitTorrent Sync-OLD

Share this post


Link to post
Share on other sites

Hi all,

I am quite new in the linux world and I would appreciate if someone could give me the way (step by step) to update from 2.3.8 to 2.4 on Raspberry-pi.

Thank you very much in advance

Share this post


Link to post
Share on other sites

@Manu.74 The way itself depends on 2 aspects:

1) how did you install 2.3.8 on your RPI: manual install? our repo pacakge? Manual package installation for RPI?
2) your RPI version (RPI1 has some additional steps to install package from repo).

Share this post


Link to post
Share on other sites

@RomanZ

Hi,

Thank you for you fast answer.

I am using a RPI 3 (or perhaps a 2) and I installed it using these commands:

 

sudo sh -c 'echo "deb http://linux-packages.getsync.com/btsync/deb btsync non-free" > /etc/apt/sources.list.d/btsync.list'

wget -qO - http://linux-packages.getsync.com/btsync/key.asc | sudo apt-key add -

sudo apt-get update
sudo apt-get install btsync

 

cd /usr/bin/

sudo wget https://download-cdn.getsync.com/2.3.8/linux-arm/BitTorrent-Sync_arm.tar.gz

sudo mv btsync btsync1

sudo tar zxvf BitTorrent-Sync_arm.tar.gz

sudo service btsync start

 

sudo nano /etc/rc.local

to add:

/usr/bin/btsync –webui.listen 0.0.0.0:8888

Exit 0

 

sudo reboot

 

if it is easier, I can install it on a fresh raspian install

Thank you very much for your help

Manu

 

Share this post


Link to post
Share on other sites

@Manu.74 Okay, so you are using official package not on RPI1. upgrade is rather straightforward for you: follow this instruction. It is very similar to what you had before, but note that URL and package name has changed. Once you'll install new package, it will automatically migrate all your settings from the old one.

@aosaigh Kind of. The package you refer to is an old "BitTorrent Sync". Now you need to install "Resilio Sync" package (see my response to @Manu.74 with the link to article with instructions). There is no update for existing BitTorrent Sync package (and not planned, as we are migrating to Resilio Sync).

Share this post


Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.