[Solved] Upgrade to Resilio Sync 2.4 on QNAP TS879-Pro failed, not starting

Recommended Posts

Hello all,

today I tried to upgrade from BitTorrent Sync 2.38 to Resilio Sync 2.4 on my QNAP TS879-Pro.

Not only the upgrade failed but also no further installation of Sync is starting on my NAS. I've tried removing the app an reinstalling and restarting the NAS vice versa. I've even tried the x86_64-Version even when my QOS is only 4.2.2.

Is the 2.3.8-version available somewhere or are there other solutions to my problem?

Best regards


Link to post
Share on other sites

HI GeHoGo,


I also tried updating this morning from 2.38 to 2.4 on my oldy but goldy QNAP TS439. I used the x86 Version from the Downloadpage and ran also into resiliosync not starting up at all (also tried all other versions available for manual download that are nor ARM) - A fast quick and dirty research by simply starting the resilio binary from shell shows the problem:

[/share/MD0_DATA/.qpkg/ResilioSync] # ./rslsync status
./rslsync: symbol lookup error: ./rslsync: undefined symbol: _ZNSt7num_putIcSt19ostreambuf_iteratorIcSt11char_traitsIcEEE2idE

I'm running latest QNAP 4.2.2-something that comes with libc261

Hopefully the devs can fix that shortly?

p.s.: the 2.3.8 Version is in the QNAP App Store for direct installing available. Just do a search there and you will ran directly into it ;-)

--rgds marcO


Link to post
Share on other sites

All good here! Cheerz!


[/share/MD0_DATA/.qpkg/ResilioSync] # ./resilio-sync.sh start
Starting resilio-sync service
By using this application, you agree to our Privacy Policy, Terms of Use and End User License Agreement.

Resilio Sync forked to background. pid = 4697
[/share/MD0_DATA/.qpkg/ResilioSync] # ps fax | grep -i resil
 4697 admin     33888 S   /share/MD0_DATA/.qpkg/ResilioSync/rslsync --config /share/MD0_DATA/.qpkg/ResilioSync/resilio-sync.conf

Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.