Timothy

[Solved] Migrating to rslsync on Linux

Recommended Posts

Hello,

I am trying to migrate to rslsync from btsync on Fedora 24. Previously, I just ran btsync from my home folder but this time I installed rslsync from the package as described here: https://help.getsync.com/hc/en-us/articles/206178924

The problem is that this installs in a new location and cannot see any of my old synced folders. Also, this instance doesn't appear to even have access to my home directory. Is there an easy way to give it access and migrate my old shared folders over?

Thanks!

Share this post


Link to post
Share on other sites

Timothy,

Migration happens between btsync package <-->  resilio-sync package, and between btsync binary <--> rslsync binary, but not across. 
So if you have been launching btsync as a binary (or even via some of your scripts) and then installed resilio-sync package, no settings will be migrated. 

You can edit /etc/resilio-sync/config.conf file and change "storage_path" to what btsync binary was using. Or copy the files from older storage to /var/lib/resilio-sync.

 

Share this post


Link to post
Share on other sites

Thanks for the help but this didn't solve any of my problems. /etc/resilio-sync/config.conf doesn't exist. Copying the contents of .sync to /var/lib/resilio-sync doesn't seem to do anything. And resilio-sync still doesn't have permission to even access my home directory. What am I doing wrong?

I was using the binary because there wasn't a package available when I started using btsync but I would prefer to use the package as the updates will be automatic.

Share this post


Link to post
Share on other sites
4 hours ago, Timothy said:

/etc/resilio-sync/config.conf doesn't exist.

Did you install rslsync package? Do you have /etc/resilio-sync/config.json file there?

So with settings copied from .sync to /var/lib/resilio-sync, resilio-sync still starts as if freshly installed? Did you also copy .SyncUser? 

 

4 hours ago, Timothy said:

resilio-sync still doesn't have permission to even access my home directory

See what user resilio-sync runs and give that user rw access to your home direcotry. 
Actually any specific details would really help! like: see the resilio-sync process running, listing of its storage, its config, permissions, etc. 

Share this post


Link to post
Share on other sites

Yes, I installed the repository and installed the package from there via dnf (replaced yum in the most recent Fedora). config.json is there but no config.conf. I changed the paths in that file to the location of my old btsync paths. No luck.

.SyncUser won't copy. Even root can't do it for some reason... I copied it's contents over to the new .SyncUser and it still looks the same.

I granted rslsync access to my home directory, however it still doesn't seem to have access to the BitTorrent Sync directory in my home directory. I can't figure out why, I've tried everything I can think of.

 

I would happily provide more details but I'm not quite sure what your looking for. Can you be more specific? I'm not exactly a linux superuser.

Thanks again for your help.

Share this post


Link to post
Share on other sites

Timothy, 

whatever option you pick - pointing to old storage, or moving files from old to new - don't forget about
1) permissions. package runs under rslsync user. So that user shall have access to the files, or better become the owner of them. and of course have rw to the shares. 
2) if you pick transferring settings from old storage to new, better move, not copy. When moving, files preserve their id in the system at least. And manually creating .SyncUser### and putting the files there is a bad idea, i'm pretty sure that won't work. 

 

can you please write to support and submit the config.json file, listing of you old storage, listing of /var/lib/resilio-sync (ls -al output), and sync.log from either storage. 
And instead of service restart, use stop / start. 

Share this post


Link to post
Share on other sites

Installing package and running it as the current user helped: 
edit file /usr/lib/systemd/user/resilio-sync.service and change "WantedBy=multi-user.target" to "WantedBy=default.target". Save, and then do 

systemctl --user enable resilio-sync

Share this post


Link to post
Share on other sites
On 9/30/2016 at 2:56 PM, Helen said:

Installing package and running it as the current user helped: 
edit file /usr/lib/systemd/user/resilio-sync.service and change "WantedBy=multi-user.target" to "WantedBy=default.target". Save, and then do 


systemctl --user enable resilio-sync

On Fedora shouldn't this be? 

sudo service resilio-sync start 

Share this post


Link to post
Share on other sites

I try similar solution on my raspberry pi. I had binary btsync and wanted to move to rslsync package. I moved .sync folder to /var/lib/resilio-sync and changed and  "WantedBy=multi-user.target" to "WantedBy=default.target" Still no success. Any tips?

Share this post


Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.