pal

[Solved] Docker loss of network connection

Recommended Posts

I just setup resilio on two Macs and a iPhone and everything is in sync. Today i tried my server and used the official docker container. However after around half of my files synced the website is not accessible anymore. My (upload) client recognises no more available peers. Attaching to the container or restarting is not possible, i have to restart docker to gain access to the container. However after 1 or 2 minutes of syncing the connection is lost again and the container is unresponsive.

The logs right when the connection is lost:

second try after docker restart:

Share this post


Link to post
Share on other sites

Dear Helen!

Thank you for your feedback. During my debug tries i found out that my server is not responding due heavy swapping to the harddrive. I allowed Docker to take to much RAM and the system startet to swap. With all the pressure (Resilio (Sync in indexing), the System itself (OSX) and Backups (TimeMachine)) i think its fair to assume that Resilio wasn't at fault in this situation. I reduced to available RAM to Docker and restarted the Server. The sync could finish without any further problem and the container is responsive since then.

Thank you for your help!

Kind regards
pal

Share this post


Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.