hannahbanana

Says peers are offline, but they are online...

Recommended Posts

Hi there

I've been having a persistent issue with 3 macs seeing each other on a local network.

Periodically, they all reset / are switched off / sleep etc, and when they're back on, it's hit or miss as to whether they think the others are online. I frequently have the problem of all 3 being online (in the sense that they can reach the internet, ping one another on LAN etc), but in the ResilioSync interface, the PEERS status for each folder is "0 of 0". This is the same on each computer, despite the fact that when sitting in front of each one individually, they are all online (outside of ResilioSync, anyway). I saw another (since closed) post that seemed similar, that says the issue had something to do with UPnP, but the details of the resolution were in a support ticket - so I'm unable to try any solutions that may have been presented... any suggestions?

ALL running OSX 10.11.6 and Resilio 2.4.1

Thanks!

Share this post


Link to post
Share on other sites

the problem might be in network being up earlier that Sync after Mac wakes up from sleep. There was indeed a topic about that, and that person enabled UPnP on their router and resolved the issue. You need to also keep UPnP option checked in Sync preferences. 
Try restarting Sync after Macs wake up from sleep and network is up. See if it helps. 

Share this post


Link to post
Share on other sites

Hi there

I have actually got UPnP already enabled on the router - several devices already use this and it's working fine. I have had Sync with UPnP both checked and unchecked, it doesn't make any difference.

If I go to any of the computers and switch from wifi to ethernet or vice-versa, it can suddenly see all the others online, and if I switch back again it keeps working OK too.

It's strange - today, one of the instances of Sync says 1 of 2 peers online, the other says 0 of 2 - so computer A is seeing computer B, but computer B thinks that computer A is offline?

Share this post


Link to post
Share on other sites

I had this problem, which support walked me through. When connecting back to Ethernet from Wi Fi, disable Wi Fi. The wrong IP address is being pushed to your router. 

Share this post


Link to post
Share on other sites

I must be having a different problem then... I usually have wifi disabled on these macs as they're permanently hooked up to ethernet. The only reason I've ever re-enabled wi-fi is to temporarily overcome the issue of sync thinking other computers are offline!

These macs are used primarily as media centres, hooked up to TVs. Prefer not to interact via keyboard / mouse at all, we used to just leave them on & use the remote for day-to-day functions. But now I've got to log into them all at least once a day to get sync working again. It's driving me mad, it used to just work!!!

Thanks for your suggestion anyway though :-)

Share this post


Link to post
Share on other sites

When you just leave them on and use the remote, I assume the Macs are awake and remain in a logged-in state?  That is, when you say that you've "got to log into them," does this mean you just have to use the Macs via keyboard/mouse, or that you first have to enter in a password via a log-in screen? 

If you *don't* have to enter in a password via a log-in screen, then the issue is something having to do with the listening port and things not getting forwarded properly from the router.  UPNP *should* work (does your router let you see what UPNP reservations have been made?), but worst case is you could set up port forwarding and make sure the Macs are on a static IP.

Share this post


Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.