geoffwea

Read Only Peers not peering with each other.

Recommended Posts

hi

I'm new to Resilio Sync. I've shared my first folder from my server with my first peer, and all is well; peer 1 pulls down the data.

When I share the same folder to a second peer, the second peer pulls down data in the folder as expected, but only ever 'sees' the server. The peers do not see each other, although do have an entry under 'inactive' for each other, noted as 0 of 0 peers.

Both shares are as Read Only.

Its like my peers don't like each other, and will only see the server from which the share was 'issued'.

The server see the first peer, and shows the second peer as inactive, and shows 0 of 0 peers next to it. 

It did use a gold image for the second peer created from the first, but device unlinked then gave it  new device name / user, and joined to network. 

I do recall a message saying time difference too great, but can't recall which of my 3 devices generated it, although it was when I joined peer number 2.

Sounds like a riddle.

What have a done wrong? Should I start from scratch on the peers? What would this look like. Perhaps sudo dpkg-reconfigure bysync might reset the peers?

Version 2.4.1, upgraded from Free to Pro on Server. Older versions on Pi 3 peers (OSMC)  2.0.93 as this version has low CPU demands.

Thanks in advance, Geoff.

Edited by geoffwea

Share this post


Link to post
Share on other sites

Further Info which may assist:

1. Both peers have different fingerprints, device names and usernames.

2. As an experiment I tried making peer 2 the owner of a folder shared from the server, and then I shared that folder the folder with peer 1. Nothing happens, just pending approval noted on peer 1. Peer 2

Peer 1 was cloned from Peer 2 image. I've shared Advanced Folders.

I tried sharing from server to peer 1 again, and the server definitely sends, and peer 1 receives beautifully, however server says its peering with Peer 2, yet its actually peering with peer 1; the server says peer 1 is inactive.

If I stop the btsync service on peer 2, the server says its still peering with it. All peers are on the same time, and time zone etc.

I think by cloning my OS (peer 1 was cloned off peer 2 disc image) then changing device name, user name that there might be a residual identity which confuses the swarm.

I think I read somewhere that its  hard to replace a btsync identity, however Helen has provided instructions here which indicate that its quite OK.

Cheers, Geoff.

w

Share this post


Link to post
Share on other sites

I've poked around my OSMC looked for a sync folder which might hold a residual identity. I'm thinking that there is a residual identity which is propagated to clones, even when a new device name / identity is created in that clone (and the clone is reconfigured via reconfiguration process using sudo dpkg-reconfigure btsync command), and that perhaps because of this when a folder is shared from server to clone, the original peer and its clone don't play nicely as they see each others identity as the same, rather than different. I don't suppose the server likes seeing 2 peers with unique identifiers either. 

If i look in the  /var/lib/btsync fold there is a hidden directory called .SyncUser[someuniquenumber]. 

Should  I  edit / delete this folder, then reinstall / reconfigure / unlink or otherwise to give this clone, and subsequent clones their own unique identity. 

I suppose, worst case i could do a sudo apt-get remove btsync, delete the directory /var/lib/btsync, then do a sudo apt-get install btsync to start fresh with each clone? Perhaps is a non nuclear option, such as editing this file......

What do you think? 

Cheers, Geoff. 

Edited by geoffwea
clarity

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now