stevegoldenberg

Trouble shooting two instances running on Linux

Recommended Posts

I am trying to run Resilio Sync 2.4.1 on a Raspberry pi 3 running Raspbian. I followed these instructions: Installing Sync Package On Linux and the service comes up with two instances running, here is the output of ps -axu | grep resil to demonstrate:

rslsync    660  0.1  0.7  84232  7544 ?        Ssl  14:56   0:03 /usr/bin/rslsync --config /etc/resilio-sync/config.json
pi        1160  0.1  0.7  70872  6636 ?        Ssl  14:56   0:02 /usr/bin/rslsync --config /home/pi/.config/resilio-sync/config.json

I have a resilio-sync direction in /etc/ with the following files in it:

-rw-r--r--   1 root root  201 Sep 29 08:55 config.json
-rwxrwxr-x   1 root root  496 Sep 29 08:54 init_user_config.sh
-rw-r--r--   1 root root  222 Sep 29 08:54 user_config.json

and I have a launch script in in /etc/init.d/. These should all be vanilla from the install instructions but I can't figure out why two instance are launching?

the config.json looks like this:

{
    "storage_path" : "/var/lib/resilio-sync/",
    "pid_file" : "/var/run/resilio-sync/sync.pid",
    "agree_to_EULA": "yes",

    "webui" :
    {
        "listen" : "0.0.0.0:8888"
    }
}

And the user_config.json looks like this:

{
    "storage_path" : "{HOME}/.config/resilio-sync/storage",
    "pid_file" : "{HOME}/.config/resilio-sync/sync.pid",
    "agree_to_EULA": "yes",

    "webui" :
    {
        "listen" : "127.0.0.1:8888"
    }
}

 

I'm also curious how to change the user that is used to launch the service at boot. I'd prefer the user "pi" over the user "rslsync" since it will be easier to manage the permissions. 

 

Share this post


Link to post
Share on other sites

@stevegoldenberg In official package for debian-based OS, Sync can run in 2 ways: as your current user (systemctl --user start resilio-sync) and as rslsync user (systemctl start resilio-sync). It looks like you used both ways and as result got 2 instances running simultaneously. Same is applied for systemctl "enable" command. Just pick which one is more convenient for you and use only one way.

Share this post


Link to post
Share on other sites

Thanks @RomanZ, however in the daemon launch script, there is only a single config file specified, and therefore launched. 

DAEMON=/usr/bin/rslsync
SYNC_USER=rslsync
CONFIG=/etc/resilio-sync/config.json

Also, I changed the SYNC_USER but the daemon still launches with "rslsync" - how do you change the launch at boot user?

Share this post


Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.