Resilio sync on Ubuntu


Recommended Posts

I followed the guide here https://help.getsync.com/hc/en-us/articles/206178924. I got everything setup and working. I then restarted my computer and now I have two instance of rslsync running. One is running under user rslsync and one is running under my username. When I try to access Resilio through 127.0.0.1:8888 I get to an instance that haven't been setup, I think it is the one running under rslsync (it suggest rslsync as the name for sync node). How can I remove one of the instances? Which one is best to keep, then one running under rslsync or my username? I guess keeping the one running under my username will make it easier in terms of folder and file access but maybe there is some other downside to it.

Link to post
Share on other sites

I installed it  a few minutes ago. With the rslsync user I got a lots of problems, now I've changed to my user an it works fine.  Did you use both systemctl commands from the quote underneath? If, you should disable the rslsync user by using 

sudo systemctl disable resilio-sync

That should work for you

Quote

Enable sync service automatic startup as user rslsync:


sudo systemctl enable resilio-sync

Enable sync service as current user:

edit file /usr/lib/systemd/user/resilio-sync.service and change "WantedBy=multi-user.target" to "WantedBy=default.target". Save. Then enable the service:


systemctl --user enable resilio-sync

Greets from good old Germany

Olaf 

Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.