[Solved] Android document picker for SD card shows no options on Marshmallow


Recommended Posts

Hello! I'm running stock Marshmallow on my Asus Zenfone 2. 

I have a problem with trying to access my SD card on Resilio Sync. 

With other applications, I am taken to the document picker and am able to choose my SD card and choose the root SD folder to grant permissions. 

I have done that with Total Commander and X-Plore among other applications so I know this is not an OS bug. 

When I select the SD card in Resilio Sync however, I'm taken to a document picker with nothing to pick. 

I have unistalled and reinstalled Sync several times, trying various options like clearing the cache, but have the same problem. 

You guys have the right idea but the implementation seems to be faulty. 

Please advise. And hopefully fix this? I have a pro license and am a paying customer of this software. ☺ Would love to sync my files to the SD card instead of my internal phone memory. 




Link to comment
Share on other sites

that is something new, cause at this step all  handling is passed over to Document Provider. Can you please make a screen and send it to support? Also, please send the logs from the phone, though "Contact Support" menu. You will be later able attached the screen recording in reply to "report received" acknowledgement mail

Also, send this info:
1) where the SD card mounted. 
2) if you have a Terminal installed, type command 'mount' and send the output. Usually Terminals allow copying text from a terminal window. 
3) Open "Contact Support" menu, in the E-mail field instead of your mail address type "SNC.DBG.SD" and hit "Send" (envelope icon), at the bottom of the screen see if your SD card is listed as available storage. If not, type "SNC.DBG.SD.ENABLE" and also hit "Send". Try using the SD card again.

And do other apps see the sd card on this same view?? 

Link to comment
Share on other sites

Intriguing. I went into the Storage setting and it says SD card.

However, when I view with Total Commander, it says USB.

But X-plore also lists it as an SD card.

It is mounted off /storage/xxxxx

I was able to get the access for X-plore and Total Commander ...maybe QuickPic as well (don't recall if I needed to do this for Quickpick but probably did) and perhaps others, but Sync is the only app that I have tried to gain access to the SD card and doesn't work.

Link to comment
Share on other sites

  • 1 month later...
  • 3 years later...

i have exactly this same problem on ASUS ZENPAD8.
My application calls picker and no SDcard to pick.
SDcard is ok, because if I want to see files on SDcard using system File Explorer - SDcard is working, files and folders are displayed.
Calls in application probably are ok too, because my application works fine in Android Studio emulator with emulated SDcard.

I think, my problem is in tablet settings, but I don't know where. 

Please explain to me how you solved it - I didn't understand it from the Helen description in the thread.

Link to comment
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.