flabbamann

FileDelayConfig - Am I doing something wrong?

Recommended Posts

Hi,

my main use case is syncing photos and music from my desktop to my NAS (for backup and to access them when my pc is off) and to an offsite backup system. So usually I copy the files to my computer, do some metadata edits, and then the files don't get touched anymore.

Let's say i rip a CD (by MediaMonkey or CDex), then add some metadata it did not automatically find, add the cover, let MediaMonkey analyze the volume, etc... I end up having like 4 copies of each track on the remote systems archive, because sync starts transferring them immediately.

To prevent this I added the extensions to FileDelayConfig:

{ "*.jpg": 180, "*.mp3": 180, "*.flac": 180, "*.ogg": 180, "*.doc": 10, "*.docx": 10, "*.dwg": 10, "*.dxf": 10, "*.indd": 10, "*.ppt": 10, "*.pptx": 10, "*.psd": 10, "*.stl": 10, "*.vsd": 10, "*.xls": 10, "*.xlsx": 10 }

But this doesn't seem to work. Sync still starts to transfer the files immediately.

I have a regular sync setup on Win10 64-Bit, not running as a service.

Share this post


Link to post
Share on other sites

re-checked. indeed, only default 10 sec delay was honoured, not bigger. Bad design. So until the fix is released, you can setup "*.mp3": 10, etc only. 
Sorry for the troubles caused. 

Share this post


Link to post
Share on other sites

I have the same issue, which I spent ages trying to fix, only to find that this feature doesn't do what I need.

I have a couple of folders that get files dropped into them from JDownloader and Get_Iplayer. Those programs then do some work on the files and Sync decides that the files cease to exist despite them being there.

I need either for Sync to look again and see that there are files there to sync or to delay indexing them until the programs have finished their work. So I'm keenly awaiting a fix for the FileDelayConfig issue.

Share this post


Link to post
Share on other sites

Was it finally fixed?

I have no success with the following FileDelayConfig config:

{ "*.rdf": 10800, "*.json": 10800, "*.sqlite": 10800, "*.sqlite-shm": 10800, "*.sqlite-wal": 10800, "*.js": 10800, "*.bak": 10800, "*.tmp": 10800, "*.sbstore": 10800, "*.pset": 10800 }

 

Share this post


Link to post
Share on other sites

yes, it was fixed quite a time ago. This config works fine in the lab. What's your rescan interval? I bet file's processed when folder is being rescanned. Disable rescan or increase it accordingly. 

Share this post


Link to post
Share on other sites
10 minutes ago, Helen said:

yes, it was fixed quite a time ago. This config works fine in the lab. What's your rescan interval? I bet file's processed when folder is being rescanned. Disable rescan or increase it accordingly. 

folder_rescan_interval: 21600
disk_low_priority: true
config_save_interval: 1200
log_size:1

Others are default values.

The FileDelayConfig file resides in:
d:\private\.sync\
directory.
 

Using Resilio Sync v2.5.6.
 

I see in the log at least 4 updates of
Mozilla_Profile\Profiles\test\webappstore.sqlite-wal
within the same minute.

Share this post


Link to post
Share on other sites

why is it in d:\private\.sync\ do you launch it with a config? is it your storage? what sync version you use? 
Can you just share the details about your setup and debug logs? Thanks.

Share this post


Link to post
Share on other sites
7 minutes ago, Helen said:

why is it in d:\private\.sync\ do you launch it with a config?

Because it was adviced to the .sync directory by:
https://help.resilio.com/hc/en-us/articles/207491426-Setting-Delay-Time-For-Syncing-Windows-Only-

Also I did not like to put data to C (system) drive, so I changed default folder location.

Using Resilio Sync v2.5.6, as posted in previous post.

Share this post


Link to post
Share on other sites

Where was it advised to use .sync directory?? The article says that FileDelayConfig is located in storage folder, and on Windows it's %appdata%, not .sync.  

Please clarify, which exactly did you change and how exactly  - default folder location (the directory where sync shares are located by default) or storage folder (directory where Sync keeps its settings, including FileDelayConfig)? If the former, than your FileDelayConfig is not taken into account. 

Do you launch Sync with a config? is  "d:\private\.sync\"  your storage? What is your config exactly? 

Share this post


Link to post
Share on other sites

Maybe I should move the FileDelayConfig from my "private" folder to
C:\Users\user_name\AppData\Roaming\Resilio Sync\
folder?

This way my local FileDelayConfig config of my "private" folder will become global, isn't it?

Share this post


Link to post
Share on other sites

Yes, sure! This is what the guide says :
Open FileDelayConfig (Located in the Storage folder).
if we check the link for Storage folder we'll see:
Windows: 
C:\Users\user_name\AppData\Roaming\Resilio Sync\ 
(will be Resilio Sync Service if you run Sync as service)

 

Not sure where you saw it advise to use .sync.  

Share this post


Link to post
Share on other sites

File delay is a global Sync setting and is to be located in storage folder. On  Windows storage folder is C:\Users\user_name\AppData\Roaming\Resilio Sync\ 
(will be Resilio Sync Service if you run Sync as service) . 

>Do I need to restart Resilio Sync to make effect of FileDelayConfig edit?
Yes, the guide has :
"3. Save the file and restart Sync."
step. Please follow the instruction you've been looking at! 

>IgnoreList file belongs to \folder\.sync\ directory or to the C:\Users\user_name\AppData\Roaming\Resilio Sync\ ?
Ignorelist is a per share setting. If we look at the guide on IgnoreList, we'll see:
"IgnoreList is located in the hidden ".sync" folder inside your sync share."

 

Share this post


Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.