nexlevel

[Solved] I know it's been done but..."Don't have permissions to write to selected folder." alert is back

Recommended Posts

Greetings Experts,

Yes, i know that this topic has been covered a number of times. The issue that I have is that I have still not been able to find a resolution to it. 

  • This is a new setup of the latest available Resilio plugin on FreeNAS 9.10
  • Directory that I want to sync is already existing in FreeNAS and has guest/nobody permissions set
  • Through shell of jail after creation of storage which maps source /mnt/volume/dataset to destination /media/resilio, I have added the resilio user to the nobody group with  pw usermod resilio -G nobody
  • I restart the jail
  • Reattempt to connect via webgui and continue to see the "Don't have permissions to write to selected folder." alert

What I need to know is:

  • Do I need to create a specific user/group for the directory that I want to share? And then add the resilio user to that group?
  • Why would there be a permission error for a directory that is essentially open to anyone who has access to it?

Thanks in advance for any help.

Share this post


Link to post
Share on other sites

Well...I guess this was an exercise in figure some stuff out on your own cause you're not likely to get anywhere waiting for someone to help.

  • So I decided that my first inclination was the correct one and created a new user/group and recursively gave it ownership of the directory that I wanted to sync.
  • Then I again performed the step from bullet 3 above as outline in the "Configure Permissions" section of this article https://forums.freenas.org/index.php?threads/btsync-configuration-guide.22927/ but this time using the group ID rather than the group name
  • Restarted the Resilio jail
  • And whallah, no more permissions errors

Hopefully this will help someone else having this same issue to quickly get resolution. It would be awesome if someone could post that it is mandatory to create a new user/group and place the resilio user in that group via the shell in the jail, rather than making the directory open with guest/nobody ownership.

I guess I just did didn't I. ;-) 

Share this post


Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.