Sign in to follow this  
koevet

Firewall question

Recommended Posts

Hi!

I have successfully installed Resilio Sync on a headless Ubuntu server (16.04).

Currently my firewall (ufw) is disabled and I'm not 100% sure which ports I should allow for Rsync to work correctly. Is port 3000 enough?

Thanks!

Share this post


Link to post
Share on other sites

Yes, the page you linked is the very first page I have consulted, but still I'm fairly confused (actually, I have seen better documentation).

It seems that If I open the listening port (as configured in Resilio setting) or I don't open it, nothing really changes. Files keep on synchronizing normally.

Any idea why?

 

Share this post


Link to post
Share on other sites

As I wrote, there is no router involved. The Resilio instance is installed on a headless ubuntu server, with only port 80 and 443 open.

I have disabled the relay server on all folder (but not the tracker), but still files get synchronized.

Share this post


Link to post
Share on other sites

Well technically you are wrong. There is always a router involved even though you don't see it. In your initial statement you didn't specifiy which ports your server has access to.

How can you be sure that all other ports are closed for this server? I'd love to see a tcp dump on the external interface filtering on the host ip of the other client that is syncing to that server. I don't really think you know that only port 80 and 443 are accessible.

Share this post


Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

Sign in to follow this