g3blv

Synology NAS link has wrong port

Recommended Posts

I've got Resilio sync running on a Synology NAS. When I click on the Resilio icon when I'm logged in to the NAS it gives me the wrong port in the link and sends me to http://[NAS_IP]:28888 while it should be http://[NAS_IP]:8888 (where I can login). When I was previously running BTSync on the NAS it was on port 8888. When I installed Resilio on the NAS I guess 8888 was occupied by BTSync so it got port 28888. I recently removed BTSync from the NAS since I'm using Resilio now. I changed the config file for Resilio to 8888 for consistency with the other Resilio installations I have. But it seems like the NAS still thinks it is on port 28888. How can I fix this so that I get the right port in the link?

Share this post


Link to post
Share on other sites

I reinstalled Resilio and it reverted to port 28888. In the GUI I can't change the port since there is an exclamation mark and text that say "Connection setting overwritten by config". How can I  change port?

Share this post


Link to post
Share on other sites

To change the actual port used by Resilio Sync you have to edit the sync.conf file in '/volume1/@appstore/resiliosync/var'. Assuming you are installed on volume 1. You'll see a section with 'listen":"0.0.0.0:xxxxx', change whatever the x's are to the port you want.

 

Not 100% positive on changing the link that Syno shows in the package tab but I think it is in '/volume1/@appstore/resiliosync/app/config'. However, I've changed mine and it did not update in the Syno gui, but I have not rebooted which may be required.

Share this post


Link to post
Share on other sites

I have the same issue, or at least I think its my issue, - but I don't understand how to implement steps suggested by Robert.

Syncing is working but deleted files continue to show with message, "not available"

Share this post


Link to post
Share on other sites

The changing of the port after an update does get frustrating after a few of them. Any chance of being able to make the change through the webUI at some point? The option appears to be there but grayed out.

Share this post


Link to post
Share on other sites

@isaacrdz Unlikely. WebUI port needs to be configured prior running the binary. Also, we got free port for Synology and do not plan to change it anymore. We had to change in the past due to company split.

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now