VooPoc

[Solved] Cannot create new folders

Recommended Posts

Hi Guys,

I get a message when creating folders "you do not have permission to write to this directory".

It's Ubuntu 16.04.2.  Resilio is 2.4.5 (903).

The service is configured for user: rslsync and group: media.  The locations of the files have for example group "foo" with read and write for that group.  User rslsync is a member of that group, but it still cannot create folders via the web interface.  When I execute commands in shell as rslsync, I can create folders and content within the same locations.

I have no idea why it's giving me this message.  Anyone?  Logs (debugging enabled) also doesn't appear to give any verbose output when clicking the 'New Folder' button.

Thanks, 

Share this post


Link to post
Share on other sites

perhaps these are extended permissions issue. with command "getfacl Foldername'  check who's the owning group. Add rslsync to that group with 'usermod -g groupname rslsync" 

See if it helps. 

Share this post


Link to post
Share on other sites

Hi Helen,

rslsync is already a member of that group.  Like I mentioned if I execute shell as rslsync, it can create folders and permissions are fine.  The only way I've been able to get it to currently work is by having rslsync the owner.

Thanks,

Share this post


Link to post
Share on other sites

well, basically giving rw access to the user should have worked, but making it the owner is surely the solution. 

Share this post


Link to post
Share on other sites

Its a workaround, I wouldn't say its a solution.  These are user files and the owner should be the user.   I don't understand why it doesn't work, any other ideas?

Share this post


Link to post
Share on other sites

Then please give rw access to rslsync user: in File station open folder preferences -> Permissions, create -> rslsync, full access, or just rw. 

Share this post


Link to post
Share on other sites

Hi Helen,

Folder has:

drwxrws---  6 something  something           6 Apr 24 18:56 Resilio/

group has:

something:x:1003:rslsync

The rslsync user can write to this folder, but sync's GUI cannot.

Share this post


Link to post
Share on other sites

sorry, my bad, mixed up with another "no permissions' on a Synology. 

Is there a reason for the setgid bit on the directory? try and remove it. 

Share this post


Link to post
Share on other sites

then there are some extended permissions on this folder or the parent folder! 

is there a chance to run Sync with the current user that actually has rw access to the folder? 

Share this post


Link to post
Share on other sites

I'm experiencing a similar issue on Linux Mint 17.3 (based on ubuntu).

The webinterface states that it cannot find the folders set up in an earlier version of Resilio Sync.

When I tried to change the default location (which has been changed from the desired /home/myuser/sync to the new  /home/myuser/sync/share supposedly during an update), then the web interface tells me: "You do not have permission to write to this directory." However, the directory and all subdirectories are set up using my user and group rslsync. Also, my old folders have the status "Folder not found".

/home and /home/myuser have

drwx------ myuser:myuser

/home/myuser/sync has

drwxrwxr-x myuser:rslsync

Needless to say that rslsync and myuser have the group rslsync assigned.

Interestingly enough:

When I create a folder /testrsl (<- in the file system root) with

drwxrwxr-x myuser:rslync

then everything works fine. The webinterface accepts this folder.

Maybe the UI tries to open the folders step by step and fails, because it is not allowed to open /home & /home/myuser? This would explain, why it succeeds with /testrsl but fails with /home/myuser/sync

[edit: correct typo]

Edited by T_T
correct typo

Share this post


Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.