scottfrey

Raspberry Pi Zero W failing to properly install Resilio-sync

Recommended Posts

Following the official guide with a completely up to date install of Jessie Lite

Using these instructions: https://help.getsync.com/hc/en-us/articles/206178924-Installing-Sync-package-on-Linux?mobile_site=true

after the second run of sudo apt-get update I get back: 

Reading package lists... Done                                                  

W: Duplicate sources.list entry http://linux-packages.resilio.com/resilio-sync/deb/ resilio-sync/non-free armhf Packages (/var/lib/apt/lists/linux-packages.resilio.com_resilio-sync_deb_dists_resilio-sync_non-free_binary-armhf_Packages)

W: You may want to run apt-get update to correct these problems
Upon installing  (sudo apt-get install resilio-sync) it returns:

 

Get:1 http://linux-packages.resilio.com/resilio-sync/deb/ resilio-sync/non-free resilio-sync armhf 2.4.5-1 [9,293 kB]

Fetched 9,293 kB in 4s (1,992 kB/s)       

Selecting previously unselected package resilio-sync.

(Reading database ... 31606 files and directories currently installed.)

Preparing to unpack .../resilio-sync_2.4.5-1_armhf.deb ...

Unpacking resilio-sync (2.4.5-1) ...

Processing triggers for systemd (215-17+deb8u6) ...

Processing triggers for man-db (2.7.0.2-5) ...

Setting up resilio-sync (2.4.5-1) ...

Job for resilio-sync.service failed. See 'systemctl status resilio-sync.service' and 'journalctl -xn' for details.

invoke-rc.d: initscript resilio-sync, action "start" failed.

dpkg: error processing package resilio-sync (--configure):

 subprocess installed post-installation script returned error exit status 1

Processing triggers for systemd (215-17+deb8u6) ...

Errors were encountered while processing:

 resilio-sync

E: Sub-process /usr/bin/dpkg returned an error code (1)
 
I can successfully enable the service, however, when I try to start the service it fails. 
sudo systemctl start resilio-sync

Job for resilio-sync.service failed. See 'systemctl status resilio-sync.service' and 'journalctl -xn' for details.

systemctl status resilio-sync.service returns:

● resilio-sync.service - Resilio Sync service

   Loaded: loaded (/lib/systemd/system/resilio-sync.service; enabled)

   Active: failed (Result: start-limit) since Tue 2017-05-09 04:38:42 UTC; 1min 48s ago

     Docs: http://help.getsync.com/

  Process: 4697 ExecStart=/usr/bin/rslsync --config /etc/resilio-sync/config.json (code=killed, signal=ILL)

  Process: 4694 ExecStartPre=/bin/chown -R rslsync:rslsync /var/run/resilio-sync (code=exited, status=0/SUCCESS)

  Process: 4691 ExecStartPre=/bin/mkdir -p /var/run/resilio-sync (code=exited, status=0/SUCCESS)

journalctl -xn returns:

No journal files were found.

 

Also, the instruction "In /etc/apt/sources.list change the line as follows:" is rather unclear, as there is no line that looks like that. I've interpreted it to mean add the line at the end, so that my sources.list looks like:

deb http://mirrordirector.raspbian.org/raspbian/ jessie main contrib non-free r$

# Uncomment line below then 'apt-get update' to enable 'apt-get source'

#deb-src http://archive.raspbian.org/raspbian/ jessie main contrib non-free rpi

deb [arch=armhf] http://linux-packages.resilio.com/resilio-sync/deb resilio-syn$
I don't know if that is right or wrong or causing the problem
 
I've gotten this to work in an older install on a Raspberry Pi3 (though I've never been able to run as the Pi user.)
 
Does Resilio work under 2017-04-10-raspbian-jessie-lite?
 
What have I missed?
 

 

Share this post


Link to post
Share on other sites

I've confirmed that this failure still occurs when using an older Pi Zero (non wireless) and when using 2016-05-27-raspbian-jessie-lite.

So, its not a Zero W issue and it's not a new Jessie-lite issue. I'll have to try on a Pi 3 next and see if it is a Zero hardware issue. It would really be a shame if it can't run on a Zero at all

 

 

Share this post


Link to post
Share on other sites

Following the instructions I am able to install and start successfully on a Pi3. Both old and current builds of JessieMoving the successfully installed SD card to a Pi Zero W, Resilio does not start on boot. manually starting generates the same error as before:

Active: failed (Result: start-limit) since Tue 2017-05-09 04:38:42 UTC; 1min 48s ago      
Docs: http://help.getsync.com/

http://help.getsync.com/ does not show any results for "start-limit" nor Pi Zero.

Clearly there is something with the Pi Zero hardware that is causing this

Share this post


Link to post
Share on other sites

Hello? Lots of people reading this, no one has any information? 

@Helen, any thoughts on this? I haven't found anything regarding Pi Zero on Resilio's site other than this post. Is this a new issue or am I just the first person to ever test this? 

Share this post


Link to post
Share on other sites
On 5/9/2017 at 7:46 AM, scottfrey said:

Duplicate sources.list entry

check the resilio.lists file and verify that it has only one source. it shall have line "deb http://linux-packages.resilio.com/resilio-sync/deb resilio-sync non-free" without quotes. 

I though there's been a number of topics about different RPis all with the same problem, most of them boil down to manually replacing armhf binary with arm. Download it form the site and put instead of the current usr/bin/rslsync binary.  

 

Share this post


Link to post
Share on other sites
Quote

I though there's been a number of topics about different RPis all with the same problem, most of them boil down to manually replacing armhf binary with arm. Download it form the site and put instead of the current usr/bin/rslsync binary.  

Tried that. Manually launching runs fine, but not after enabling it with Systemctl. Starting with systemctl still throws the same errors. 

Also, would this bandaid not get undone when running apt-get upgrade?

 

Share this post


Link to post
Share on other sites

цhat error will you get if you manually launch Sync with command (you might need sudo for that) 
/usr/bin/rslsync --config /etc/resilio-sync/config.json

Share this post


Link to post
Share on other sites

I haven't tried launching it with /usr/bin/rslsync --config /etc/resilio-sync/config.json

However, manually starting with rslsync works after installing,

but after running: sudo systemctl enable resilio-sync

it never works again. that has been consistent behavior. 

It always throws the "start-limit" error after it's been enabled in systemctl once. Even if it is subsequently disabled. I don't have a build with Resilio installed to test right now as I have been trying to get Syncthing to work due to lack of progress on Pi Zeros with Resilio. I'll build up another one and break it and see what launching it in config mode gets me.

 

Share this post


Link to post
Share on other sites

Hi Guys

sorry if I de-dust again this discussion.

I'm facing the same or almost similar problem.

This morning i dedicate a few hours in trying to figure out what is happening.

I have 2 raspberry PI : 1x Mod. 2 and 1x Mod. 3

I have 1 single Micro SD card and latest downloaded image of Jessie Raspbian lite (2017-07-05-raspbian-jessie-lite.img)

Test #1.

Burned the MicroSD with Jessie-Lite, put into P3, startup, follow instructions as per here :
https://help.resilio.com/hc/en-us/articles/206178924-Installing-Sync-package-on-Linux?mobile_site=true

Resilio Sync start perfectly.

Test #2

Removed the MicroSD card from P3, plugged into adapter, burned again with same Jessie Lite, plugged into P2 and repeat the same instructions above on how to install resilio sync.

Here is there result:

Quote

 

Processing triggers for systemd (215-17+deb8u7) ...

Setting up resilio-sync (2.5.6-1) ...

Job for resilio-sync.service failed. See 'systemctl status resilio-sync.service' and 'journalctl -xn' for details.

invoke-rc.d: initscript resilio-sync, action "start" failed.

dpkg: error processing package resilio-sync (--configure):

 subprocess installed post-installation script returned error exit status 1

Processing triggers for systemd (215-17+deb8u7) ...

Errors were encountered while processing:

 resilio-sync

E: Sub-process /usr/bin/dpkg returned an error code (1)

 

When I try to run manually....

Quote

 

pi@raspberrypi:~ $ /usr/bin/rslsync --config /etc/resilio-sync/config.json

Segmentation fault

pi@raspberrypi:~ $ sudo systemctl status resilio-sync

resilio-sync.service - Resilio Sync service

   Loaded: loaded (/lib/systemd/system/resilio-sync.service; enabled)

   Active: failed (Result: start-limit) since Sat 2017-08-05 08:09:43 UTC; 17min ago

     Docs: https://help.getsync.com/

  Process: 752 ExecStart=/usr/bin/rslsync --config /etc/resilio-sync/config.json (code=killed, signal=SEGV)

  Process: 744 ExecStartPre=/bin/chown -R rslsync:rslsync /var/run/resilio-sync (code=exited, status=0/SUCCESS)

  Process: 740 ExecStartPre=/bin/mkdir -p /var/run/resilio-sync (code=exited, status=0/SUCCESS)

 

Aug 05 08:09:43 raspberrypi systemd[1]: Unit resilio-sync.service entered failed state.

Aug 05 08:09:43 raspberrypi systemd[1]: resilio-sync.service holdoff time over, scheduling restart.

Aug 05 08:09:43 raspberrypi systemd[1]: Stopping Resilio Sync service...

Aug 05 08:09:43 raspberrypi systemd[1]: Starting Resilio Sync service...

Aug 05 08:09:43 raspberrypi systemd[1]: resilio-sync.service start request repeated too quickly, refusing to start.

Aug 05 08:09:43 raspberrypi systemd[1]: Failed to start Resilio Sync service.

Aug 05 08:09:43 raspberrypi systemd[1]: Unit resilio-sync.service entered failed state.

 

 

Test #3

Removed the MicroSD card, plugged straight into P3 (AS IS).... working perfectly !

 

Anybody can help me ?

Thanks

BB

Share this post


Link to post
Share on other sites

I just tried one thing, after reading all the post about Raspberry.

I downloaded the binary ARM from here :
https://download-cdn.resilio.com/stable/linux-arm/resilio-sync_arm.tar.gz

Untar, replace the original rslsync in /usr/bin with this one extracted from the archive.
Magic !
Everything is running perfectly now

I have 2 question:
Please note that I made a test #4 which is the same procedure you recommend here (https://help.resilio.com/hc/en-us/articles/206178924-Installing-Sync-package-on-Linux?mobile_site=true) but sleeping away the ARM64 paragraph and I notice that, it still download the ARMHFversion.
Is there a way when installing on a Raspberry PI 2 to download the version ARM and not the ARMHF ?

Last question, connected to this above is... when i will do an upgrade (apt-get)  how I will avoid to run into this problem again ?
Don't tell me that I have to download the binary and replace it ....

Thanks for your support and great job.
BB

Share this post


Link to post
Share on other sites

This is the screenshot of the download for the Linux package for Raspberry PI2 (without adding ARM64 architecture):

59881c412fe65_ScreenShot2017-08-05at11_36_16.thumb.jpg.0fff7f7e05b1b362efdfbafc48d10c6e.jpg

I skipped this passage :

59881c5b88c89_ScreenShot2017-08-07at09_50_59.jpg.c88738b48e242cfb8c64a98537065d47.jpg

so it should be downloading the ARM 2.5.6-1 without 'HF'

Why is still downloading the ARMHF version ?

Share this post


Link to post
Share on other sites

For some unknown reason, Raspbian uses ARMHF default architecture. As a result, apt-get downloads ARMHF build from our repo. This is not something we can fix as it is in Raspbian code.

Share this post


Link to post
Share on other sites
Quote

This is not something we can fix as it is in Raspbian code.

I suspect this is not accurate, as Resilio is literally the only application that I have had this problem with, every other install I have done has gottent the correct binary for the different architectures. Even when the install is first setup on the Pi3 and SD card moved tot he Pi Zero, it installs the correct binary for every thing else I have installed and updated. 

I have had to move to the much slower Syncthing as a reasult of this problem. You've lost any chance of a subscription from me.

 

Share this post


Link to post
Share on other sites
15 hours ago, scottfrey said:

I suspect this is not accurate, as Resilio is literally the only application that I have had this problem with, every other install I have done has gottent the correct binary for the different architectures. Even when the install is first setup on the Pi3 and SD card moved tot he Pi Zero, it installs the correct binary for every thing else I have installed and updated. 

I have had to move to the much slower Syncthing as a reasult of this problem. You've lost any chance of a subscription from me.

 

Indeed I'm facing the same problem....

I'm in testing mode of expanding torrent sync among all our branches and they buy the proper license.

Unfortunately all the devices are running OSX, RASPBIAN, DEBIAN LINUX, etc.

Wherever we use RASPBIAN (very small office, just to update a few folders), every time a new version is release I have to seat down, ssh to these oversea office, shutdown resilio sync, apt-get update, replace the binary with the correct one and then restart resilio.

This morning I have update one very long time sleeping unit here in my office.
Run apt-get update, updated almost 134 packages.
133 smooth perfectly.
1 hang.... guess which one !!! Resilio Sync.

Annoying.....

I have looked into synching too but I feel that, while it's a great in terms of security, it's too slow and it's not as somebody say "work out of the box".

Share this post


Link to post
Share on other sites

According to this link the Pi Zero is the same architecture as Pi 1:

https://wiki.debian.org/RaspberryPi

So follow the instructions on https://help.resilio.com/hc/en-us/articles/206178924-Installing-Sync-package-on-Linux and use the "For Raspberry Pi 1" section, not the "For arm64 architecture" section. In fact, I don't think the "For arm64 architecture" has to be used for any Raspberry Pi at all - as noted by brokenby2703, it installs the armhf by default anyway.

The line "sudo apt-get install resilio-sync:armel" installs the package so no need to proceed further after that.

P.S. Someone needs to clean up those instructions.

Share this post


Link to post
Share on other sites

Just tried reproducing my steps and not working now. I had it running though with many commands and experimentation so not sure which steps in which order worked! Back to the drawing board...

Share this post


Link to post
Share on other sites

I think I've got it working. These were my steps:

echo "deb http://linux-packages.resilio.com/resilio-sync/deb resilio-sync non-free" | sudo tee /etc/apt/sources.list.d/resilio-sync.list
wget -qO - https://linux-packages.resilio.com/resilio-sync/key.asc | sudo apt-key add -

sudo apt-get update

sudo dpkg --add-architecture armel

sudo apt-get update

sudo apt-get install resilio-sync:armel
 

In the second last step, you will get a warning. It had me stumped for a while but eventually I just ignored it. The warning message you'll get is:

W: Failed to fetch http://mirrordirector.raspbian.org/raspbian/dists/jessie/InRelease  Unable to find expected entry 'main/binary-armel/Packages' in Release file (Wrong sources.list entry or malformed file)

W: Failed to fetch http://archive.raspberrypi.org/debian/dists/jessie/InRelease  Unable to find expected entry 'main/binary-armel/Packages' in Release file (Wrong sources.list entry or malformed file)
 

Well it seems to be working but I welcome any comments on whether I did the right thing.

 

resilio.png

Share this post


Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.