stephrdev

Disk wake up without data access

Recommended Posts

Hi,

it seems that resilio sync on Linux wakes up the disk of a synced folder even if nobody is accessing any files nor is any other peer connected. Only two internal files are accessed:

17:10:07.212935 rslsync(26891): O /storage/bucket0/data/Sync/documents/.sync/ID
17:10:16.485407 rslsync(26891): RCW /storage/bucket0/data/Sync/documents/.sync/ID
17:10:16.485407 rslsync(26891): CW /storage/bucket0/data/Sync/documents/.sync/ID
17:10:16.485407 rslsync(26891): O /storage/bucket0/data/Sync/documents
17:10:16.490268 rslsync(26891): RC /storage/bucket0/data/Sync/documents
17:10:16.490599 rslsync(26891): RCWO /storage/bucket0/data/Sync/documents/.sync/ID
17:10:16.490599 rslsync(26891): CW /storage/bucket0/data/Sync/documents/.sync/ID
17:10:16.491477 rslsync(26891): O /storage/bucket0/data/Sync/documents/.sync/Archive
17:10:16.495143 rslsync(26891): RC /storage/bucket0/data/Sync/documents/.sync/Archive

This happens exactly once a day. Is there a way to prevent resilio sync from accessing any files if no-one is connected/only if disk is already awake or woken up by actual data access?

I already played around with folder_refresh_interval and other stuff, even if this is not related to the named files (.sync/ID and .sync/Archive).

Any hint on this would be nice. Thanks a lot.

Share this post


Link to post
Share on other sites
16 hours ago, stephrdev said:

played around with folder_refresh_interval and other stuff

what exactly other stuff? what's your rescan_interval? 

Share this post


Link to post
Share on other sites

folder_rescan_interval is 86400. This could be a reason indeed. But I thought its not because no files in the folder are accessed besides the two mentioned above. Can I increase or fully disable rescanning and only rely on inotify?

Share this post


Link to post
Share on other sites

periodic rescan does not read the files themselves, sync only reads the database and checks files' size and mtime. 

yes, technically you can disable rescan (set it zero), but generally it's not advisable and we cannot guarantee correct syncing. 

Share this post


Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.