giblets

Sync service on Linux starting as different user?

Recommended Posts

Hi there! I am hoping someone can help me as I am a bit lost.

I have setup Resilio Sync on Linux (Raspbian to be exact) but now I think I have done something wrong and it keeps trying to start Sync as a different user. I have about 7 folders synced with 15gb so I really don't want to start again.

It all started when I began trying to get the service to run at boot. It was working fine prior to this point.

I tried to edit the service file via the following
sudo nano /lib/systemd/system/resilio-sync.service
and changed the User & Group variables to pi. I also changed the WantedBy to default.target

I edited /usr/lib/systemd/user/resilio-sync.service to also have WantedBy to default.target

This was the last point I could see the folders when I checked by opening the gui.

I tried a crontab by:
sudo crontab -e
And adding:
@reboot rslsync

I think I tried a different function in here to add it to the systemd as another way to try and get it to load on boot, but I can't get my terminal to recall it for some reason.

I found a guide that said this may be an issue as I initially set it up under the rslsync user. I changed it to pi after install as I am syncing the files on a USB and rslsync did not have the correct permissions to access the media. So I ran the following:

systemctl --user disable resilio-sync
sudo systemctl disable resilio-sync
systemctl --user enable resilio-sync

I found a guide that said when running on headless to always force it to run as the current user to use -
sudo loginctl enable-linger pi

Now the service does start at boot (which I have checked by opening the gui directly after boot), but it doesn't show my folders - it loads into the setup box asking to set a username and password. 

Have I destroyed my setup or have I just made a faux par by making it load as a different user? Thanks in advance for the help, I am a bit stressed as I was getting this setup before I depart on a vacation.

Share this post


Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.