myradon

Resilio Sync 2.5.4 and 2.5.5 performance and sync problems

Recommended Posts

My systems are suffering from Major performance- and sync-problems! I've got 2 macOS systems and 2 NASses running first on 2.5.4 and now on 2.5.5 (just upgraded today). The App in macOS just stalls system; Activity monitor gives a lot of times; CPU over 100% and Not Responding. systems have problem with syncing with each other. Arch Linux NAS on my office has been offline for days but is actually running. Now in the office it syncs. Webpage of both Linux systems are terribly slow for a while and then they are fine and back again. 

This is output of Arch Linux system after restarting;

* rslsync.service - Resilio Sync per-user service
   Loaded: loaded (/usr/lib/systemd/user/rslsync.service; enabled; vendor preset: enabled)
   Active: active (running) since Sat 2017-07-08 16:14:49 CEST; 19min ago
 Main PID: 280 (rslsync)
   CGroup: /user.slice/user-1000.slice/user@1000.service/rslsync.service
           `-280 /usr/bin/rslsync --nodaemon --config /home/raymond/.config/rslsync/rslsync.conf

Jul 08 16:34:31 nas rslsync[280]: [20170708 16:34:31.456] D! 21ReverseHTTPConnection::set_error[0x00007f89e6969270][56] 103 (EOF)
Jul 08 16:34:31 nas rslsync[280]: [20170708 16:34:31.458] D! 21ReverseHTTPConnection::set_error[0x00007f89e6c3cd60][67] 103 (EOF)
Jul 08 16:34:31 nas rslsync[280]: [20170708 16:34:31.463] D! 21ReverseHTTPConnection::set_error[0x00007f89e6c3cd60][55] 103 (EOF)
Jul 08 16:34:31 nas rslsync[280]: [20170708 16:34:31.483] D! 17TrackerConnection::set_error[0x00007f89e69877a0][16] 104 (Connectio
Jul 08 16:34:31 nas rslsync[280]: [20170708 16:34:31.483] D! 17TrackerConnection::set_error[0x00007f89e697a5f0][17] 104 (Connectio
Jul 08 16:34:31 nas rslsync[280]: [20170708 16:34:31.484] D! 17TrackerConnection::set_error[0x00007f89e69648f0][116] 104 (Connecti
Jul 08 16:34:31 nas rslsync[280]: [20170708 16:34:31.538] D! 21ReverseHTTPConnection::set_error[0x00007f89e6c04cd0][16] 103 (EOF)
Jul 08 16:34:31 nas rslsync[280]: [20170708 16:34:31.538] D! 21ReverseHTTPConnection::set_error[0x00007f89e6c050c0][17] 103 (EOF)
Jul 08 16:34:31 nas rslsync[280]: [20170708 16:34:31.920] D! 21ReverseHTTPConnection::set_error[0x00007f89e6c3cd60][56] 103 (EOF)
Jul 08 16:34:31 nas rslsync[280]: [20170708 16:34:31.925] ZIP: Can't locate [css/style.css] in zip, error -100.

and after a while;

* rslsync.service - Resilio Sync per-user service
   Loaded: loaded (/usr/lib/systemd/user/rslsync.service; enabled; vendor preset: enabled)
   Active: active (running) since Sat 2017-07-08 16:39:06 CEST; 1h 31min ago
 Main PID: 444 (rslsync)
   CGroup: /user.slice/user-1000.slice/user@1000.service/rslsync.service
           `-444 /usr/bin/rslsync --nodaemon --config /home/raymond/.config/rslsync/rslsync.conf

Jul 08 18:10:10 nas rslsync[444]: [20170708 18:10:10.361] D! 10SyncTcpReq[0x00007f1d4d634400]: EOF - error: 103 (application protocol level timeout)
Jul 08 18:10:10 nas rslsync[444]: [20170708 18:10:10.361] D! 10SyncTcpReq::set_error[0x00007f1d4d634780][-1] 103 (application protocol level timeout)
Jul 08 18:10:10 nas rslsync[444]: [20170708 18:10:10.361] D! 10SyncTcpReq[0x00007f1d4d634780]: EOF - error: 103 (application protocol level timeout)
Jul 08 18:10:10 nas rslsync[444]: [20170708 18:10:10.361] D! 10SyncTcpReq::set_error[0x00007f1d4ea9d5e0][-1] 103 (application protocol level timeout)
Jul 08 18:10:10 nas rslsync[444]: [20170708 18:10:10.361] D! 10SyncTcpReq[0x00007f1d4ea9d5e0]: EOF - error: 103 (application protocol level timeout)
Jul 08 18:10:10 nas rslsync[444]: [20170708 18:10:10.562] D! 10SyncTcpReq[0x00007f1d4ea9d8a0]: EOF - error: 0 (Success)
Jul 08 18:10:11 nas rslsync[444]: [20170708 18:10:11.952] D! 10SyncTcpReq[0x00007f1d4d1047a0]: EOF - error: 0 (Success)
Jul 08 18:10:12 nas rslsync[444]: [20170708 18:10:12.240] D! 21ReverseHTTPConnection::set_error[0x00007f1d4d1434b0][86] 103 (EOF)
Jul 08 18:10:12 nas rslsync[444]: [20170708 18:10:12.343] D! 10SyncTcpReq::set_error[0x00007f1d4c401aa0][-1] 103 (application protocol level timeout)
Jul 08 18:10:12 nas rslsync[444]: [20170708 18:10:12.343] D! 10SyncTcpReq[0x00007f1d4c401aa0]: EOF - error: 103 (application protocol level timeout)

 I'm so annoyed this is my third major problem with Btsync/ Resilio on about 3 years.

Share this post


Link to post
Share on other sites

I've got 2 Nasses; 1 is running Ubuntu 16.04 LTS with your Repository and 1 is running Arch Linux with Resilio through AUR. Somehow on both mac's Resilio Sync slows down system that much my keyboard doesn't respond. When I force Quit Resilio in Activity Monitor I can type again. Resilio also shows beachball on both my systems. Here is a screenshot after I forced quit Resilio and started;5964fd9da336a_ScreenShot2017-07-11at18_32_04.png.1f64d2a1d1d0c9099c5aa203dfaae8ae.png

Edited by myradon

Share this post


Link to post
Share on other sites

On the Arch machine (2.5.5.1030) something is off with adding Predefined hosts. I add host and port then click on add. Nothing! field underneath  stays empty. Tried next folder same, next same, next same "No predefined host". Open first folder 6 times the same predefined host. So I deleted 5 and closed. When I open Preferences all predefines hosts are gone! WTF?! There should be 1. Actually all these predefined hosts were configured on version 2.4.x

One specific folder keeps showing Progress "0% a few seconds" on my Macbook and Arch linux. I now this folder hasn't been add new or modified files for a while. 

Both Linux Resilio Webpages have the same problem when it comes to showing connected peers in Peers list. You should be able to have detailed view on which peers are connected whe you select Synced with. The accordion doesn't open. I only see a triangle;

59650f997ae0b_ScreenShot2017-07-11at19_48_55.thumb.png.15b3f60ca81220a0081391bd86637f64.png

Okay excuse me I was wrong. It apparently shows up after x seconds;

5965113d6991b_ScreenShot2017-07-11at19_51_15.thumb.png.5326878312bf665b371ea4a0376ad910.png

Arch Linux;

[raymond@nas ~]$ ps -aux | grep rslsync
raymond    297 98.1 16.7 1366032 660324 ?      Ssl  18:39  76:33 /usr/bin/rslsync --nodaemon --config /home/raymond/.config/rslsync/rslsync.conf
raymond    542  0.0  0.0   9024   808 pts/0    S+   19:57   0:00 grep rslsync

 

Edited by myradon

Share this post


Link to post
Share on other sites

I've updated Resilio on both Macs to 2.5.6(1034) and 1 Arch Linux NAS also to 2.5.6(1034). Systems don't hang anymore cause of crazy CPU-times. Also Predefined host option are available but somehow in some sync-folders they got deleted. I didn't remove them for sure!

1 folder the progress "0% - a few seconds " is gone. 1 is still showing "0% - a few seconds ".  On Arch linux last transfer is juli 03 and connected Mac is today. That's a bit odd.

Share this post


Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.