Latest Desktop Build 2.5.6


Recommended Posts

Dear community,

Resilio Sync 2.5.6 is now available. It may be obtained it via direct links below, or via official download page. This version is also available via auto-update, and "Check now" button.

Sync is now released under the Resilio brand, it is treated by OS as new application and will propose you to migrate all your settings from old BitTorrent Sync app (settings are backed up during migration).
Please carefully read these articles about updating to Resilio Sync and migration of settings.

Resilio Sync will make a backup copy of all your settings prior migration into "sync-v2.3.7-1471003319.backup"-like folder (version and timestamp may vary). If you decide to return to 2.3.*, you'll need to manually copy the content to your storage folder, remove Resilio Sync and be aware of next downgrade drawbacks:

  1. You'll downgrade to "Free" version and you'll have to re-apply license manually. File association with license files *.btskey is broken so you'll need to apply license in BTSync UI
  2. Linking new devices to downgraded Sync is not possible. You'll need to recreate identity if you want to link some new device.
  3. Downgrade is not supported for Selective Sync folders (as all placeholder files are renamed to *.rsl*). If you downgrade and your Sync has Selective Sync folders, your files are going to be deleted on all peers.

Direct Download Links:

A list of what's new, improved, changed, and fixed in this version is available in the change log.


Link to comment
Share on other sites

15 hours ago, mr.canada said:

how does this version differ from v2.5.10015 that was made available over the last week to address the problem of getting stuck with 100% cpu usage.  Is this the same version just promoted to Released status, or are there other difference?



Have you tried giving it a shot and see if it fixed it for you? Since the old version is still available there is not really a reason not to try it out I guess :-)

As with every company that ships a software product not all changes that will get merged in a new release make it to the public changelog.

Link to comment
Share on other sites

Just updated to 2.5.6

Changed 2 files in one of my synchronized folders and since then i see permament self-resonating cacsade of synchronization of this 2 files within triangle of peers. =)

It feels like when rslsync recives changes from remote peer, it changes local files and then recieves notifications from OS about files changes induced by rslsync itself, reacts on this events like "files changed by user" and retranslates this "changes" back and further.

Edited by progmachine
Link to comment
Share on other sites

Here is logs from three peers.

charon and ceres64 are linux peers, notebook is win10 peer.

You can filter out of scope all but folder "common" and files credentials.xml and shell_history.xml in it, which is permamently synchronized within triangle of peers.

All other have the same problem, but there is huge amount of files going back and further, which is noisy (and CPU intensive waste load).


Link to comment
Share on other sites

Do ceres and charon work on the same machine? they have same IP addresses. What is ceres exactly? The thing is that Sync on it cannot change the files' attributes  - "operation not permitted" on /home/progmachine/ partition. Sync process has no permission to change files' mtime and set other attr.  This might be just he lack of rw access, or some specific  mount point parameters for the Sync user. 

Try and set mtime to a file on that mounted point:
touch -t test.txt

there's one more peer -  I suspect there's the same problem, so they pingpong the files to each other. Cannot tell for sure as I don't have logs from there. 

Link to comment
Share on other sites

Ok, this is detailed map of my devices:

On my work i have my personal notebook - it is one of this peers discussed here (Win10 OS). On it i have virtual machine with Ubuntu 16.04 x64, it's name is ceres64. Due to wifi security politics in company, DPI firewalls blocks many directions and protocols (VPN, games, RDP etc.), and bittorrent protocol is also blocked. Because of this, rslsync can't just work directly. So i have a trick - ssh tunnel from ceres64 direct to charon, which is placed at my home. May be thats why charon and ceres64 looks have the same IP.

At home I have two phisical computers: neptune and progmachine-ws0. charon is virtual machine, currently running on progmachine-ws0.

On linux boxes (progmachine-ws0, neptune, charon, ceres64), rslsync running as service with its own user id and group id. All synchronized folders are set with progmachine user id, and btsync/rslsync group id with sgid flag, so all existing files and new files in that folders must be accessible for write to rslsync daemon, due to "drwsrwsr-x" access pattern. But I'll check all permissions and see what will happen.

Link to comment
Share on other sites

Interesting situation:

progmachine@ceres64:~/apps/common/profile/mucommander$ ls -l ../
итого 12
drwsrwsr-x 2 progmachine btsync 4096 сен 17  2016 argouml
drwsrwsr-x 4 progmachine btsync 4096 сен 17  2016 mucommander
drwsrwsr-x 4 progmachine btsync 4096 сен 17  2016 purple
progmachine@ceres64:~/apps/common/profile/mucommander$ ls -l
итого 40
-rw-rw---- 1 progmachine btsync  179 окт  8  2013 action_keymap.xml
-rw-rw---- 1 progmachine btsync  312 мар  7  2015 bookmarks.xml
-rw-rw---- 1 progmachine btsync 1774 апр  8  2016 credentials.xml
drwsrwsr-x 2 progmachine btsync 4096 сен 17  2016 extensions
-rw-rw---- 1 progmachine btsync 2998 июн  3  2016 preferences.xml
-rw-rw---- 1 progmachine btsync   76 апр  7  2016 shell_history.xml
-rw-rw---- 1 progmachine btsync 4712 июн  3  2016 snapshot.xml
drwsrwsr-x 2 progmachine btsync 4096 сен 17  2016 themes
-rw-rw---- 1 progmachine btsync 1651 окт  8  2013 user_theme.xml
progmachine@ceres64:~/apps/common/profile/mucommander$ sudo su btsync -c "touch -t 201604080000.00 credentials.xml"
touch: установка временных отметок 'credentials.xml': Операция не позволена
progmachine@ceres64:~/apps/common/profile/mucommander$ touch -t 201604080000.00 credentials.xml

As a "progmachine" userid i can change mtime of the file, but as "btsync" user i can't, even if btsync group allowed to write.

Link to comment
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.