Recommended Posts

Hey guys,

for some reason, I'm trying to start Sync in configuration mode (Win64), using this config:

{
    "storage_path" : "./sync",
    "device_name": "my-device",
    "agree_to_EULA" : "yes",
    "check_for_updates" : false,
    "use_gui": true,
    "use_upnp" : true,
    "download_limit" : 0,
    "upload_limit" : 0,
    "rate_limit_local_peers": false,
    "lan_encrypt_data": false,
    "sync_max_time_diff": 172800,
    "peer_expiration_days": 3,
    "folder_defaults.use_relay": true,
    "folder_defaults.use_tracker": true,
    "folder_defaults.use_lan_broadcast": true,
    "sync_trash_ttl": 1,
    "send_statistics": false,
    "enable_journaling": false,

...

 

This was working fine a while ago with BTsync 1.4 and 2.0. Now I am running into two weird problems:

- Sync want's to create a new identity every time - but successfully creates database and other files in ./sync

- If I activate the webui-listener, Sync always opens a webbrowser with the webif every time (which I really don't need), even if I enable the local gui

 

The Sync.log says:

[2017-07-29 02:12:10.055] Set new identity: blah blah blah
[2017-07-29 02:12:10.060] Unable to add identity 'blah blah blah' to DB, DB is NULL
[2017-07-29 02:12:10.060] WebUISession call callback 43, ListeningSyncEvents = 1
[2017-07-29 02:12:10.062] Sending broadcast ping for 3 shares
[2017-07-29 02:12:10.062] Sending broadcast ping for 3 shares
[2017-07-29 02:12:10.070] Master Folder Controller: disconnect master folder
[2017-07-29 02:12:10.070] Master Folder Controller: no master folder
[2017-07-29 02:12:10.070] Master Folder Controller: set secret
[2017-07-29 02:12:10.071] assert failed PathVector.cpp:73
[2017-07-29 02:12:10.071] assert failed PathVector.cpp:73
[2017-07-29 02:12:10.071] MD[init]: Master Folder: create
[2017-07-29 02:12:10.071] assert failed PathVector.cpp:73
[2017-07-29 02:12:10.071] MD[init]: Master Folder: failed to create 101
[2017-07-29 02:12:10.071] Master Folder Controller: cannot create master folder (error: 101)
[2017-07-29 02:12:10.120] ZIP: Can't locate [version.json] in zip, error -100.
[2017-07-29 02:12:10.784] Sending broadcast ping for 3 shares
[2017-07-29 02:12:11.662] Sending broadcast ping for 3 shares

 

And here the content of the ./sync -folder:

11702313193513589557.1501194522.journal             17022159861700389248.1501194591.journal
381988E12B2CD149F8DB58D8E0203CAE129E665B.2.db       381988E12B2CD149F8DB58D8E0203CAE129E665B.2.db-shm
381988E12B2CD149F8DB58D8E0203CAE129E665B.2.db-wal   5685992543831202687.1501276309.journal
A47620673F788184E541310E49E904F1BCE0A57F.1.db       A47620673F788184E541310E49E904F1BCE0A57F.1.db-shm
A47620673F788184E541310E49E904F1BCE0A57F.1.db-wal   BE96FD374E6F83B3CA79D5F572B7372618984D6D.3.db
BE96FD374E6F83B3CA79D5F572B7372618984D6D.3.db-shm   BE96FD374E6F83B3CA79D5F572B7372618984D6D.3.db-wal
btsync.pid                                          debug.txt
FileDelayConfig                                     history.dat
history.dat.old                                     http.port
[ie]                                                settings.dat
settings.dat.old                                    storage.db
storage.db-shm                                      storage.db-wal
sync.dat                                            sync.dat.old
sync.log                                            sync.pid

 

Can someone help me with this time-killer?

 

Share this post


Link to post
Share on other sites
On 7/29/2017 at 5:13 AM, Xylomon said:

"storage_path" : "./sync",

what is this path exactly? That looks like a posix syntax. use full path with doule slash for windows, instruction:

Quote

While editing path, use double backslash "\\" for configuration files which will be used on Windows, and "/' for Linux and OS X configs. 

And check write permissions to this directory - Sync has no rw access there thus identity is not created. 
And I hope your config does not actually end with an ellipsis? 

 

On 7/29/2017 at 5:13 AM, Xylomon said:

I activate the webui-listener, Sync always opens a webbrowser with the webif every time (which I really don't need), even if I enable the local gui

well, once you enable webui, it's expected that webui opens. If you don't want to use web ui, just don't enable it in the log. 

Share this post


Link to post
Share on other sites

Hi, 

the path is using a subfolder "sync" in the current folder where rslsync.exe is placed. This works (I'm using this since Sync 1.4), the error is the same using another directory with full path.

Sync has r/w access to the folder. As said, it doesn't matter which directory is chosen. Sync creates files in this folder but asks for the identity next time while all the shares remain. This only happens if sync is run in configuration mode. I am really sure this is a bug.

 

I want to use the web listener for API calls or maybe accessing the web-ui sometimes, but not every time. Thats why I enabled web-ui. If this behavior has changed since it's Resilio, can you tell what is the correct way now? (sending api calls without opening the webui)

 

Thanks in advance

Share this post


Link to post
Share on other sites
18 hours ago, Xylomon said:

This works (I'm using this since Sync 1.4), the error is the same using another directory with full path.

Quite a lot has been changed in Sync since 1.4 and now full path in config file is required. With it the problem does not appear in the lab and identity creates correctly. Backslash shall be escaped in path. 

Check .SyncUser### inside your sync directory. identity.dat file cannot be created there - thus the problem. 

 

If webui option is defined in config, web ui will open automatically. this is how it works now. Comment it out in config if you don't need webui.

Share this post


Link to post
Share on other sites

Ok thanks for your detailed answer, I will try. If a static path is required now, I'll have to stay on 1.4., for my portable use case.

As a last question, can you tell how to send API calls to the rslsync if webui is disabled? I cannot find a port definition like "api listener". I add and remove folders with curl and I just don't need the browser to be opened every time - thats annoying

Share this post


Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.