SilverBlueP

Synching from Laptop (conf file) to Phone

Recommended Posts

Hello. I have been familiar with torrent for a long time, but recently trying to migrate to resilio (due to my frustration with dropbox and the limitations).

I have a Laptop (running Arch Linux) with all my data. I have set up a config file for a couple of my folders. I have posted my code below, or it's in a pastebin here.

I want to sync my Music folder to my android phone. (Samsung Galaxy S7) I installed the Sync app, and entered the "secret" of the Music folder as a key in my phone, and directed it into an empty folder called Music in my sd card. After this, my phone says it sees my Laptop as a peer, but I can't see any files in the Music folder. And it says it has synced. I check my ~/Music folder on my laptop, and it is well populated.

The reason I'm using the JSON config file is I am more comfortable with manual configs over a GUI.

{
   "device_name": "SBP-Laptop"
  ,"use_upnp" : true
  ,"download_limit" : 0
  ,"upload_limit" : 0
  ,"webui" :
  {
    "listen" : "0.0.0.0:8888" // remove field to disable WebUI
   ,"login" : "SOME UNAME"
   ,"password" : "SOME PASSWORD"
  }
 
/* !!! if you set shared folders in config file WebUI will be DISABLED !!!
   shared directories specified in config file  override the folders previously added from WebUI. */
 
  ,"shared_folders" :
  [
    {
      // required field - use --generate-secret in command line to create new secret
      "secret" : "SOME SECRET"
     ,"dir" : "Documents"
      //  use relay server when direct connection fails
     ,"use_relay_server" : true
     ,"use_tracker" : true
     ,"search_lan" : true
      // enable SyncArchive to store files deleted on remote devices
     ,"use_sync_trash" : true
      // restore modified files to original version, ONLY for Read-Only folders
     ,"overwrite_changes" : false
      // add folder in selective sync mode
     ,"selective_sync" : false
      // specify hosts to attempt connection without additional search
     ,"known_hosts" :
      [
        "192.168.1.2:44444"
      ]
    }
   ,{
      // required field - use --generate-secret in command line to create new secret
      "secret" : "SOME SECRET"
     ,"dir" : "Pictures"
     ,"use_relay_server" : true
     ,"use_tracker" : true
     ,"search_lan" : true
     ,"use_sync_trash" : true
     ,"overwrite_changes" : false
     ,"selective_sync" : false
     ,"known_hosts" :
      [
        "192.168.1.2:44444"
      ]
    }
   ,{
      // required field - use --generate-secret in command line to create new secret
      "secret" : "SOME SECRET"
     ,"dir" : "Music"
     ,"use_relay_server" : true
     ,"use_tracker" : true
     ,"search_lan" : true
     ,"use_sync_trash" : true
     ,"overwrite_changes" : false
     ,"selective_sync" : false
     ,"known_hosts" :
      [
        "192.168.1.2:44444"
      ]
    }
   ,{
      // required field - use --generate-secret in command line to create new secret
      "secret" : "SOME SECRET"
     ,"dir" : "Videos"
     ,"use_relay_server" : true
     ,"use_tracker" : true
     ,"search_lan" : true
     ,"use_sync_trash" : true
     ,"overwrite_changes" : false
     ,"selective_sync" : false
     ,"known_hosts" :
      [
        "192.168.1.2:44444"
      ]
    }
  ]
 
}

 

Share this post


Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.