syncmonkey

[Poss Bug] Pop up after logging in

Recommended Posts

I'm encountering this same annoyance.  Does anyone know if if the AutoEndTasks flag in the registry still works in the Fall Creators Update and might do the trick?  (https://technet.microsoft.com/en-us/library/cc978604.aspx ) .  I think this flag has been omitted in the Update -- but can it be added back?  I hesitate to volunteer my machine as the guinea pig to find out (but might nonetheless if no one else knows).  If so, this possibility doesn't appear to have been discussed elsewhere based on a casual Google search.  Thanks!

Share this post


Link to post
Share on other sites

OK, further research.  Here's a very extensive discussion of the autostartup "feature"/issue (and problems it's causing): https://www.tenforums.com/general-support/95776-restart-fall-creators-update-reopens-apps-before.html.  There is a workaround, a bit inelegant, but it does appear to work.  Right click on the desktop, choose "New", then "Shortcut", then enter: shutdown.exe /r /t 0 .  Then "Next", then name the new shortcut, "Restart".  Then right click on the new shortcut, choose "Properties", then "Change icon" button, then select an appropriate icon (I chose a blue curved counter-clockwise arrow).  With this specification, this shortcut restores the old pre-Fall Creators Update behavior of shutting down all programs during restart.  You can rinse and repeat to create a "Shutdown" shortcut using the command, shutdown.exe /p .

Windows team:  This is a pain in the neck, and a dangerous feature.  As someone in the above linked forum noted, re-opening open applications is not acceptable if you're working on confidential material.  There needs to be an option, or at least a Registry edit, that re-establishes historical behavior.

Resilio Sync team:  Why do most other backbground programs appear to terminate during a shutdown or restart, but Sync doesn't?  Can Sync be modified to terminate automatically notwithstanding Windows' new "feature"?

Some further similar info here: http://www.winhelponline.com/blog/stop-auto-reopen-programs-restart-windows-10/.

Share this post


Link to post
Share on other sites

Yesterday I installed an up to date Win10 (1709) on my main machine (was Win7 before) and after installation Resilio Sync starts always maximized after boot.

According to this (German) website: https://www.deskmodder.de/wiki/index.php/Autostart_Windows_10_Programme_deaktivieren_hinzufügen_entfernen there is a new feature in Windows which most likely causes this problem. With creators update 1709 Win10 tries to restart programs which was opend at last shutdown, to "improve user experience" -> cause bugs.

To validate this I've made the following tests:

  1. Disable the "Resilio Sync beim Hochfahren starten" (means: start Resilio Sync after bootup) checkbox -> Syncs starts maximized after reboot, but it should'n start at all. So my guess is that Windows starts Resilio Sync because it was running at last shutdown.
  2. Quit Resilio Sync manually before shutdown with disabled autostart checkbox -> Syncs won't start after reboot, thats OK. So Resilio Sync wasn't running at last shutdown and Windoof has no reason to start it.
  3. Quit Resilio Sync manually before shutdown with enabled autostart checkbox -> Sync starts minimized as desired. In this case the autostart is done over the checkbox and not by Windows. So it works as it should.

Oher programs like Logitech Gaming Software (for the makro-keys on my keyboard) won't show this problem, so it should be able to prevent Win10 1709 to restart a service program on reboot.

I've installed Resilio Sync normally, not as a service (maybe that would be the better option...)

Could you please investigate that in detail and provide a "bug-"fix?

 

Thanks,

Bimbo385

Share this post


Link to post
Share on other sites
On 12/4/2017 at 1:44 PM, Bimbo385 said:

Could you please investigate that in detail and provide a "bug-"fix?

 

2 hours ago, Bimbo385 said:

Is someone working on it???

 

2 hours ago, Helen said:

Unfortunately, not much can be done by Resilio's team to fix this new feature of Windows.

Please read my November 29th postings above, especially the second one, which link to detailed discussions of this new "feature"/problem introduced by the Fall Creators Update -- and, contrary to the assertion that "not much can be done", is amenable to a somewhat inelegant but very effective and easily created workaround that I also describe in detail.  The basic problem that I discuss in greater detail in these postings (especially the second one) was properly identified by others earlier in this thread (on page 1 of the thread).

Share this post


Link to post
Share on other sites

I also have this bug, and it's on my Windows 8.1 laptop, so I'd say it's not just a Windows 10 issue. I do believe it's the same issue, because I've just confirmed that if I manually close Sync before restarting, then it does indeed start minimized as it should, but if I restart with sync still running in the tray, it does not. So I'd suggest that maybe the diagnosis that it's down to a Windows 10 feature is wrong, unless that same feature has been back-ported to Windows 8.1.

Share this post


Link to post
Share on other sites
On 9/12/2017 at 3:29 PM, Helen said:

Unfortunately, not much can be done by Resilio's team to fix this new feature of Windows. Looks like only some apps get affected, not all. Please see here, for example,
http://www.winhelponline.com/blog/stop-auto-reopen-programs-restart-windows-10/  

Thank you.

Why will you not answer the questions set forth by Mr Bolt?

Mightbe the core issue is Windows but the fact remains that resilio is the only app that does not behave on my system. This it is fair to assume this issue is two fold. But the easy stance is to just refuse corporation.

Share this post


Link to post
Share on other sites

on my PC Registry editor also reopens :( Sync does not. 

We'll see what can be done , but at the moment not much can be done by Resilio's team to fix this new feature of Windows.

Share this post


Link to post
Share on other sites

I was experiencing this problem as well and had resorted to using alt f4 to shutdown my computers.

I did receive an email from Microsoft support a a couple of days ago saying a question had received an update:-

Quote

Updated (2/20/18)

There is a change with the Fall Creator’s Update where applications that have registered via RegisterApplicationRestart will re-open after a shutdown or reboot.

What changed?  The advanced Windows Update feature which restores running applications after an update has been extended to regular shutdowns and restarts initiated through power options available on the Start Menu and various other locations.  This is to create a seamless experience wherein, if you have to reboot your PC, you can pick back up from where you left off and resume being productive. 

We've heard the feedback that some of you would like to have a switch for turning on and off this feature, and have now added the ability to do this.

Once you have installed the January 31st update (KB4058258 (OS Build 16299.214)), you will be able to turn off this feature by going to Settings > Accounts > Sign-in options > Scroll down to Privacy > Toggle off Use my sign-in info to automatically finish setting up my device after an update or restart.

Note: The feature is not available on PCs that are managed by enterprises nor on home PCs that are sync’d to enterprise (work, school, etc.) email. 

Source:-

https://answers.microsoft.com/en-us/windows/forum/windows_10-performance/apps-reopening-on-start-up-after-shutdownrestart/b6d6b6b1-dc08-4ecd-aad7-088eb7cb723e

Hope this helps. has worked for me thus far. restarted my computers quite a few times just to test it

Share this post


Link to post
Share on other sites
On 2/22/2018 at 6:43 AM, calvyb said:

I was experiencing this problem as well and had resorted to using alt f4 to shutdown my computers.

I did receive an email from Microsoft support a a couple of days ago saying a question had received an update:-

Source:-

https://answers.microsoft.com/en-us/windows/forum/windows_10-performance/apps-reopening-on-start-up-after-shutdownrestart/b6d6b6b1-dc08-4ecd-aad7-088eb7cb723e

Hope this helps. has worked for me thus far. restarted my computers quite a few times just to test it

Thanks! This seems to work.  Not sure what the downside is exactly regarding updates for windows.  Ultimately I'm surprised Reselio has not released a fix for this though. Other startup apps to not suffer from this issue (ie. Google backup and sync) so there must be some developer options to prevent this.  Another workaround is running sync as a service, but I still can't get it to autoupdate when I do that.

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now