Files deleted on desktop won't delete on Android device

Recommended Posts



I clicked the + button and used "Create folder" to add my DCIM directory on my SD card to which my phone's camera saves all of my pictures.

Initial sync made sure that all my photos are on my Desktop. Now that I've got them there, I moved (ie. deleted) them to another directory on my PC so they no longer exist (hence deleted) in the Resilio Sync directory. With Read/Write permissions, I would expect Sync to now delete this pictures from my Android device, but this didn't happen.


What might I be doing wrong or did I not understand how Sync should work?


Resilio Sync app for Android version 2.5.9 (7471)

Resilio Sync app for Windows version 2.5.9 (1088)

Android version 6.0

Link to post
Share on other sites

once PC has RW access to the share, this deletion will propagate to the phone. Did you indeed use "create folder' on the phone or "add backup"?
Give more details:

1) is Selective Sync enabled on either device? 
2) Did you check History in Sync? Is there record "PC removed file"? 
3) does the file remain in Sync UI on the phone? 
4) did you try restarting Sync on either device? 

Link to post
Share on other sites

After you've posted these questions, I went back and noticed something else...

The files were actually removed from the SD card, but the problem was that the built-in Gallery app on my Android phone keeps some sort of cache which shows the pictures, but they aren't really there. Perhaps it's just showing my some thumbnails of the photos that were there but I can't open the photos.

I'm just stuck with a Gallery that has lots of thumbnails but I don't really know why they are there if they were deleted from the SD card by Sync (which was expected)

Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.