Rickard

Sync crashes when encrypted folders are enabled

Recommended Posts

I've been using Sync home for a long time, and haven't had one problem so far. But yesterday I ran into a big one. I have a file server and a laptop. Both run Windows 10 and they've been syncing quite a lot of folders for me. So yesterday I thought I'd set up an off-site backup, and as that would sync to a VPS, I'd thought I'd make that copy encrypted.

So I changed the folders I wanted to sync to the VPS to encrypted. The server is the master. I added the encrypted key on the VPS encrypted backup folders, and that seems to work very well. Almost everything is synced now. 

Then I added the folders with an RW key on my laptop, and that's when the trouble started. After a few percent of syncing, Resilio running on my laptop crashes. It doesn't matter if I run as an app or as a service. Nor does it matter if I install Resilio completely clean. Other instances tick on like there's no tomorrow. It's just my laptop that fails.

I use a Surface Book 2 with 16 GB of memory, Windows 10 completely updated.

Share this post


Link to post
Share on other sites

Ah, sorry, that would be useful information of course...

The version is Sync Home, 2.5.12 (1191).

Also, I changed back to unencrypted folders, and now everything works alright again. So it has something to do with the encryption key.

Share this post


Link to post
Share on other sites

Yes, it's the same version on all peers. I'll try to find the time to set it up again and get the logs sent to you.

It isn't the peer that has the encrypted folder key that crashes, nor the 'master' peer. It's a third peer that has the RW key that crashes if that folder also has an encrypted key somewhere.

Share this post


Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.