Any way to disable IPv6?


Timbo
 Share

Recommended Posts

When looking in the logs, I noticed lots of messages about lack of connection to an IPv6 tracker.  Since my ISP doesn't support IPv6, I was assuming that only local LAN peers would use IPv6 and all Internet connections would be IPv4.  Right now, it just looks like a lot of wasted time trying to talk to this tracker that it will never be able to talk to.

I don't see any option in the Advanced properties.  Is there a way to disable IPv6?

Thanks

Quote

[2018-02-26 17:35:15.561] Cached trackers:
[2018-02-26 17:35:15.561] addr 0.0 kB: 173.244.217.42:4000
[2018-02-26 17:35:15.561] addr6 0.0 kB: [2606:2e00:8003:1:ec4:7aff:fe57:108e]:4000
[2018-02-26 17:35:15.561] addr 0.0 kB: 209.95.56.60:4000
[2018-02-26 17:35:15.561] addr6 0.0 kB: [2606:2e00:0:7c:225:90ff:fe47:76a6]:4000

...

[2018-02-26 17:35:15.576] Creating TCP tracker connection to [2606:2e00:8003:1:ec4:7aff:fe57:108e]:4000
[2018-02-26 17:35:15.576] Creating uTP tracker connection to [2606:2e00:8003:1:ec4:7aff:fe57:108e]:4000
[2018-02-26 17:35:15.576] D! class TrackerTcpConn::TcpSocket::set_error[0x0000000002ebe420][-1] 10051 (A socket operation was attempted to an unreachable network. )
[2018-02-26 17:35:15.576] Closing TCP tracker connection to [2606:2e00:8003:1:ec4:7aff:fe57:108e]:4000 - error 10051 (A socket operation was attempted to an unreachable network. )

 

Link to comment
Share on other sites

8 hours ago, Gane O'dwyer said:

@Timbo ipv6 have to be disabled in your network setting and on the route. As for Sync you can use 'bind_interface' option in the Power user preferences of the app  to allow Sync connect to specific network interface.

Well, disabling IPv6 for the OS is not recommended, generally. But there is no route to the Internet, so why the app keeps trying is just bad behaviour and waste of resources.

Also, you're aware that IPv4 and IPv6 use the same interface, so how would specifying the interface to bind to will help?  I checked it out before posting. I specifically don't want to do this, as I have multiple NIC's in these machines.

I believe I will go ahead and disable IPv6 on my WHS 2011 box and see if there is any fallout.  But this should have been a setting when IPv6 support was being added, I was surprised when advanced options didn't have it.

Link to comment
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

 Share