BtbN

Hide Main-Window on startup

Recommended Posts

I'm using latest Sync 2.5.13 on Windows 10 64bit, not as a service.

Everything works fine, except for one minor annoyance I just can't figure out:
The Sync Main Window opens up on every startup, and I then have to manually close it to hide sync in the tray area.

A search on this Forum resulted in two things:

Add /MINIMIZED to the Run entries in the registry. When I checked them, they already had that by default.

The other thing I found out was that if I manually exit Sync before rebooting/shutting down, the main window does not show up on the next boot.
But manually closing Sync before every shutdown is even more tedious then closing the Window on every boot.

Is there really no way to make it respect the /MINIMIZED option no matter what? Why does that even happen, does it not properly handle shutting down on system shutdown?

Share this post


Link to post
Share on other sites

After the Fall Creator’s Update, Windows automatically reopens apps that were open upon restart or shutdown.  This includes Sync.  To disable this, navigate to the following location:

Settings > Accounts > Sign-In Options

Scroll down to Privacy on the right and then set the following to Off:

Use my sign-in info to automatically finish setting up my device and reopen my apps after an update or restart. 

This will fix the issue and Sync will still start, but will do so minimized to the tray.  Note that this will disable the automatic reopening of other apps upon restart, if that is a deal breaker for you.

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now