Not enough free space - When there is enough


Recommended Posts

Equipment : 1.) Raspberry Pi with USB drive attached. 2.) Windows PC

My linux side is reporting "Not enough free space on the drive" when there is clearly enough. It's folder is a external USB. It will only create the folder names but won't sync any files .

Any ideas ?

2018-08-05 21_57_57-Window.png

2018-08-05 21_56_46-Sync Home _ pizerow.png

Link to comment
Share on other sites

  • 1 month later...
  • 2 weeks later...

I have encountered the same issue with raspbian stretch, plenty of free space, trying to sync small folder with several files.

Linux raspberrypi 4.14.70+ #1144 Tue Sep 18 17:20:50 BST 2018 armv6l GNU/Linux 

Filesystem      Size  Used Avail Use% Mounted on
/dev/root        30G  1.1G   27G   4% /


Link to comment
Share on other sites

  • 2 months later...

Had the same problem.  All 3 windows 7/10 machines.  2 computers with external hardrives plugged into USB were fine.  Computer on LAN with NAS said not enough hardrive space even though there was over 3TB.  I downgraded one with NAS to 2.5.13 and it APPEARS to have solved the problem.  BTW, this problem appeared overnight during christmas break.  No issues for months and months, then all of a sudden two folders would not sync.  

Link to comment
Share on other sites

  • 1 month later...
  • 1 year later...
On 10/20/2018 at 5:29 AM, ghoff said:

I see the same error using resilio-sync_2.6.1-1_armel.deb on a Pi Zero.  I downgraded to 2.5.13-1 and that resolved the problem.

Been hunting for the last 4 hours for an older deb file for armhf I can install - because on my Pi Zero W running "buster" the installer installs a binary that won't run - at all - from systemd - I got past this issue by manually copying the binary rslsync from the armhf tar file - but the Pi Zero W install is complaining about "Not enough free space on the drive." - when it's running on a 128 GB SD card :

Filesystem      Size  Used Avail Use% Mounted on
/dev/root       117G  1.4G  111G   2% /

rslsync will create the directory structure of my sync folder, but it's just a stack of empty folders...  

I've tried adding/appending this to my ~/.conf/resiliosync/config.json file  :


    "disk_check_free_space": false


and it won't even start (and various combinations of the above) - so I removed that...

Pi Zero W details

x@frambo:~/.config/resilio-sync $ uname -a
Linux frambo 5.4.72+ #1356 Thu Oct 22 13:56:00 BST 2020 armv6l GNU/Linux

Where did you @ghoff find a copy of 2.6.1-1?  Because I only seem to be able to download 2.7x versions...

Probably going to log a ticket as I'm paying for pro version...

Note also : I've got rslsync running perfectly on 5 x Ubuntu 20.04 desktops, and 3 RPi 4B (one running aarch64, two running armhf), plus 2 x NTC CHIP (Jessie) and 1 x Oracle Pi+2E (running Armbian Xenial), plus my work's Windows 10 laptop...

Link to comment
Share on other sites

  • 2 weeks later...
  • 4 weeks later...

@dankshit The files are still in the resilio debian repository, but you can't browse them.

But don't use either of those, instead do what @thePowerOfDot suggests and change the free space option.  I had accidentally upgraded to the current version and the out of space error returned and I was able to resolve it with the free space change.


Link to comment
Share on other sites

Same Problem here. Raspberry pi Model 3. Raspbian Buster Version 10.

Resilio Sync 2.7.2 (1375)

21g available (83% in use), and Resilio mentiones that it is running low on disk space.

the workaround to edit the "disk_min_free_space" option did not work for me.

EDIT: do you need further informations for troubleshooting? That issue is pretty annoying..

Edited by gl00mer
Link to comment
Share on other sites

  • 3 months later...

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.