eltopo

[Solved] Android 7.0 phone can't open destination folder

Recommended Posts

Hello,

My Android 7.0 phone got update today from Google Play Store and now it's running Sync 2.6.0 (7871)

I have 2 connected folders and now they both show "Can't open the destination folder".

The destination folders are on my phone's external SD card and I am pretty sure Sync 2.5.x didn't have this problem (I granted SD card access). The SD card is mounted correctly and I can see all synced files from a FileManager app.

I did:

1. reboot the phone

2. check System Settings / App permissions, and Sync 2.6.0 does have "Storage" permission. 

I suspect that Sync 2.6.0 somehow lost SD card access permission ... is there any way for Sync 2.6.0 to check/ask for SD card access again? or any ideas to fix this issue?

Thanks.

photo_2018-08-06_12-15-10.jpg

Share this post


Link to post
Share on other sites

It's not permission, it's about the path to the directory -  Sync cannot find the directory by the path it has. Remove the share from Sync and add it back.

Share this post


Link to post
Share on other sites
13 hours ago, Helen said:

It's not permission, it's about the path to the directory -  Sync cannot find the directory by the path it has. Remove the share from Sync and add it back.

Thanks for the reply.

However, I am wondering why the same paths worked before with Sync 2.5.3(?) (the version before 2.6.0) but don't with 2.6.0...

And can you be more specific about "remove the share from Sync and add it back"? These folders are shared with my Home Pro Sync desktops, the phone is a linked device and it got these folders automatically (not from shared links), I don't know how to remove these folders and am afraid of doing something wrong to disturb the desktops.

Thanks. 

 

Share this post


Link to post
Share on other sites

to remove the share from Sync - tap on "i" icon - Disconnect. It will remain in Sync on desktop. Tap on the share again and reconnect it pointing to the wanted directory on SD card. 

Share this post


Link to post
Share on other sites
10 hours ago, Helen said:

to remove the share from Sync - tap on "i" icon - Disconnect. It will remain in Sync on desktop. Tap on the share again and reconnect it pointing to the wanted directory on SD card. 

Hello,

I did what you suggest.

If "Simple mode" is enabled, reconnecting the share created a new share folder with "(1)" appended (because the old share folder already existed and I couldn't rename the share name), and Sync had to re-download files under the new folder... which is not very good. 

I had to disable "Simple mode" before reconnect to get a chance to use old share name/folder, this also resulted in a long time "indexing"... well, at least it didn't re-download 30GB files.

Share this post


Link to post
Share on other sites

Changed the topic to [resolved] with a workaround: disconnect/reconnect with "Simple mode" disabled.

The cause of this problem is still a mystery to me.  I hope I won't see it in the future with new versions of Sync.

Share this post


Link to post
Share on other sites
On 8/8/2018 at 7:50 PM, Helen said:

to remove the share from Sync - tap on "i" icon - Disconnect. It will remain in Sync on desktop. Tap on the share again and reconnect it pointing to the wanted directory on SD card. 

This removes the sync from the device, but not the files stored on it. But you still have to manually re-add each one to the same location - it's not as straight forward as a mere toggling as that post might suggest.

I've just had the same issue which appears to have started on 6th of August. Presumably an update broke it. I'll be sure not to update much from now on, as is my policy with a number of apps these days.

Share this post


Link to post
Share on other sites
On 8/9/2018 at 8:44 AM, Helen said:

were the shares located in SD://Android/data/com.resilio.sync ? If so, this is the reason most likely

No, they were in SD://myrsl/, not in Android/data folder.

Share this post


Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.