clrader

New Resilio Version syncing some but not all files

Recommended Posts

I've been using Resilio for years on different machines with little to no problems, this latest update seems to have added a lot of instability.  I've tried re-establishing the SHARED FOLDERS from Scratch but I still get inconsistent behavior in some but now all shared folders.  When new files are placed in some but not all shared folders won't add those files but the hosting computer with the added file shows STATUS  of a green check mark.  The client Resilio Sync computer gives me this error.

  Capture.PNG.1e22bd7f49424e984b8db090bfe9f000.PNG

 

Any ideas of fixes.  This same host computer is able to sync other folders successfully to the same client computers on the same day.  The internet is strong and consistent at both machines and the file sizes are single files of less than 5mbs.

 

Has me stumped.

 

Thanks

Share this post


Link to post
Share on other sites

Hi,

I have found that using 2.6.0 will give that problem on all rigs that have that version. I downgraded to my previous version 2.5.13 - which has got rid of the problem. Can't find a way of downloading a previous build from the resilio website so hence why my older version is very old!

Share this post


Link to post
Share on other sites

I have the same issues with 2.6.0 and wrote a mail to the support yesterday.

In my case resilio doesn't even show the affected files, the list loads infinitely.

Seems to be a bug.

Share this post


Link to post
Share on other sites

2.6.1 seemed to make it better but didn't fix the issue which leaves me still not being able to trust the sync anymore.  Has anyone tried SYNCTHING?  I hate to downgrade Resilio Sync then have to put up with pop ups to update and never know what version is going to fix this problem.  I would be nice if  you could backup all of your sync folders before you downgrade but the process of resyncing all folders takes me forever.  I wish they'd address this major issue.

Share this post


Link to post
Share on other sites

Have you sent them your bug report? I did so, and as you see, they addressed the issue. But probably only fixed a part of the issue. So report the bug and they'll fix it. It's your decision. 

 

Share this post


Link to post
Share on other sites

I have the same problem with 2.6.1. 

It used to work fine but now it doesn't Sync some of the files with the same message as:

On 9/4/2018 at 8:34 PM, clrader said:

Capture.PNG.1e22bd7f49424e984b8db090bfe9f000.PNG

 

Share this post


Link to post
Share on other sites

I just submitted a report, Hope they can fix it. My free version worked fine. I bought the Pro version last week and now I have this problem.

Share this post


Link to post
Share on other sites

I submitted a bug report but they didn't understand what the issue was. I can't seem to have all files show up. They keep saying that it's a file that was created with a timestamp in the future but it doesn't. I never had this issue until recently. I'm considering downgrading. What version was still stable for all of you?

Share this post


Link to post
Share on other sites

I'm having the exact same problem. Downgrading one of my client machines back to 2.5.13 and re-adding the shares didn't cause the missing files to sync. Is there any way to downgrade the version on my "host" machine and preserve the existing shares?

The only thing I've found so far that works is to manually open and re-save the files (or rename them), which causes Resilio sync to now "see" them and start syncing.

Edit: This appears to be the specific error in the log file:

Quote

[2018-10-18 09:13:07.257] FC[3507]: won't forcibly index file "[Path & File Name]" - doesn't exists locally

 

Share this post


Link to post
Share on other sites
On 9/13/2018 at 9:53 PM, justjoyce said:

I guess you guys need to wait, but I am sure they are fixing it already. 

Not likely. This was reported before in 2.6.0 and instead of treating it like a critical bug, they released 2.6.1.  And then when it was obvious they installed to the wrong directory and upgrades are failing, that will be their on-fire bug they need to fix for the next release as a higher priority.

I asked for a workaround to this in the 2.6.1 thread and got no response.  It's clear something happened with their developers or QA as I see night and day difference from yester years.

In the time it took to write this point, I had another 3 files get this problem.  *sigh*

Share this post


Link to post
Share on other sites
On 10/18/2018 at 9:17 AM, mgerskup said:

I'm having the exact same problem. Downgrading one of my client machines back to 2.5.13 and re-adding the shares didn't cause the missing files to sync. Is there any way to downgrade the version on my "host" machine and preserve the existing shares?

 

To answer my own question, I was successfully able to downgrade to 2.5.13 by uninstalling and not checking "remove settings". I then re-installed using the 2.5.13 executable, launched the program, and all of the shares were still intact.

This appears to have solved the problem with certain files choosing not to sync (though I can't be certain, yet).

Share this post


Link to post
Share on other sites

I'm having the same issue as well. This is a critical/urgent issue because this is a loss of core functionality of syncing files. Developers, please acknowledge and fix ASAP.

Share this post


Link to post
Share on other sites

Same Problem here: Since version 2.6.X core functionality is basically gone, since a lot of folders not in sync anymore.

This is super critical!

@Resilio Support Forum Please advise!

p.s. as a temporary solution I replaced the problematic Resilio Sync folders with Syncthing folders. Any other solution would be great too.

Edited by Pak Kriss
Update

Share this post


Link to post
Share on other sites

Given that this bug would have been treated as a showstopper bug by any other QA manager, and still not addressed almost 3 months later (I reported it at least Aug 17), it might be time to move to alternate sync solutions.  I suspect that they are not getting the kind of revenue to properly support QA and do not have near the QA testers they actually need for all the platforms they've spread to and all the features they've added.  This issue and several others in the past year are the kind of thing you see when all your senior developers are replaced by junior developers without the experience necessary to continuously release better software.

Share this post


Link to post
Share on other sites
3 hours ago, 19feet said:

This sync issue has nothing to do with an upgrade. It was just a coincidence.

After I didn't get a response to my first request, I uninstalled resilio sync and reinstalled it. After a few days, the same phenomenon occurred again. The files are no longer synchronized. The client of resilio sync from this computer no longer appears in the clients of resilio sync on other computers. If you log in via the web gui of resilio sync, you won't get to the previous settings. It starts again with the initial setup.

 

13 hours ago, Timbo said:

Given that this bug would have been treated as a showstopper bug by any other QA manager, and still not addressed almost 3 months later (I reported it at least Aug 17), it might be time to move to alternate sync solutions.  I suspect that they are not getting the kind of revenue to properly support QA and do not have near the QA testers they actually need for all the platforms they've spread to and all the features they've added.  This issue and several others in the past year are the kind of thing you see when all your senior developers are replaced by junior developers without the experience necessary to continuously release better software.

Since I had the same problems and the integrity of file synchronization is essential, Resilio Sync was replaced with Syncthing on Ubuntu 18.10 computers.

Maybe Resilio wants to get rid of Sync business, pro and home users. Could be cash flow or profit issues in this user segment.

Share this post


Link to post
Share on other sites

The reason I originally settled on Resilio Sync is because it let me sync existing windows directories (IIRC, Syncthing requires you to create new folder structures inside of the server application -- though I might be mis-remembering).

I haven't really had success finding a good alternative that allows you to sync existing folder structures (i.e. those that need to be available to Windows users as well), unless you start looking into Dropbox/Google Drive/etc. (and then it's more of a cloud-based solution).

Any recommendations?

Share this post


Link to post
Share on other sites
22 hours ago, mgerskup said:

The reason I originally settled on Resilio Sync is because it let me sync existing windows directories (IIRC, Syncthing requires you to create new folder structures inside of the server application -- though I might be mis-remembering).

I haven't really had success finding a good alternative that allows you to sync existing folder structures (i.e. those that need to be available to Windows users as well), unless you start looking into Dropbox/Google Drive/etc. (and then it's more of a cloud-based solution).

Any recommendations?

Both Resilio Sync and Syncthing work well with existing directory structures. I do not know any limitations, but I only use Linux operating systems.

Share this post


Link to post
Share on other sites
On 9/28/2018 at 2:05 PM, Frank Maier said:

Have you sent them your bug report? I did so, and as you see, they addressed the issue. But probably only fixed a part of the issue. So report the bug and they'll fix it. It's your decision. 

 

What did Support instruct you to do? Despite you acknowledging your problem was different, they clearly DID NOT fix the problem reported in this thread, so please elaborate on what fixed your issue for you in case it helps the rest of us.  Resilio is seriously hurting their reputation by having such nasty bugs continue for months and support just goes silent on the issue.

Share this post


Link to post
Share on other sites

The problem was, that Resilio wasn't able to show which files are stuck, as I wrote in my first post in this thread. That's fixed now. As I said, only part of it was fixed, as I still have stuck files. However, I didn't had time to collect the logs again, so I wasn't able to report the issue to them

But in my experience does the support work, but they need input. It's time consuming for myself, and once I find time, I'll try to report it in detail to them again. So far I don't have the time.

But even for me, it's odd, that they still haven't fixed the problem yet. It's odd that they don't seem to have these issues. I also notice that mainly one laptop produces these problematic files which can't get synced. I suspect it's related to having the file locked for several days, with maybe some standby of Windows, but I don't know for sure.

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now