Sign in to follow this  
jocko

version 2.6.3 : Sync web-interface broken over TLS protocol

Recommended Posts

Hi

I just tried to use the lastest version 2.6.3 (1340).

About the main features, I do not yet noticed issue except for when I try to open the web-interface over TLS protocol.

With Firefox, I got the warning : SSL_ERROR_RX_RECORD_TOO_LONG (Too long answer/authorized size) and on Chrome : ERR_SSL_PROTOCOL_ERROR ( bad answer)

What I may confirm it is an issue with version 2.6.3 :

on version 2.6.0, I have no issue with the same certificate;

This certificate is also used by other servers hosting on the same server (apache; ...)

I have the same issue from my LAN or from WLAN

I used a x509.v3 certificate signed by a custom CA root (of course installed on the client side): pubkey 1024bits with a sha-256 sign mechanism

Note: I also tried to disable TLS1.3 like described in https://support.mozilla.org/en-US/questions/1222739 but it did not fix the issue.

 

Thank in advance

 

Share this post


Link to post
Share on other sites

Hi

I made an additional test by downgrading resilio sync to version Sync 2.6.2 (1330).

And I do not have this issue (still with the same certificat)

So I think the issue is only with version 2.6.3

 

Share this post


Link to post
Share on other sites

Hi

Still no answer after one month🤔

Please to note this issue prevents us from releasing the last version for users using our firmware on their NAS.

 

Share this post


Link to post
Share on other sites

Hi

Still no answer from support but I deepened more the issue with version 2.6.3.

In my conf file, force_https option is set to false and in this case I can not open resilio gui over https protocol but if I change its value to true I can open resilio gui over https protocol. (Amazing !)

I have this behaviour only with 2.6.3 (not with 2.6.2)

Anyhow it is not the expected behaviour according with the page https://help.resilio.com/hc/en-us/articles/206178884-Running-Sync-in-configuration-mode :

Quote

"force_https" - if "true" is selected, http will be disabled.

So currently force_https option is to enable/disable https instead of forcing or not this protocol on version 2.6.3 😬

Share this post


Link to post
Share on other sites

Hi

This subject is still open and I am waiting for an answer since January 26.

Thank in advance

Currently we lock this release on our firmware.

 

Share this post


Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

Sign in to follow this