LucasFarchetto

[SOLVED] Ubuntu 19.04 Problem

Recommended Posts

Hello:
I am new to the community and I wanted to inform you of this error that is appearing when I want to install Resilio-sync in Ubuntu 19.04:

 

--- console---

Active: activating (auto-restart) (Result: timeout) since Mon 2019-04-22 22:49:33 -03; 4ms ago

dpkg: error when processing the package resilio-sync (--configure):

The thread installed resilio-sync script post-installation returned the error exit code 1

Errors were found when processing:

resilio-sync

E: Sub-process /usr/bin/dpkg returned an error code (1)
 

Share this post


Link to post
Share on other sites

Same issue here. Just tried to install resilio-sync (2.6.1-1) on ubuntu MATE 19.04.

$ systemctl status resilio-sync.service
● resilio-sync.service - Resilio Sync service
   Loaded: loaded (/lib/systemd/system/resilio-sync.service; enabled; vendor pre
   Active: activating (start) since Thu 2019-04-25 20:22:47 CEST; 35s ago
     Docs: https://help.resilio.com
    Tasks: 15 (limit: 4915)
   Memory: 4.2M
   CGroup: /system.slice/resilio-sync.service
           └─5204 /usr/bin/rslsync --config /etc/resilio-sync/config.json
 
Apr 25 20:22:47 pocket systemd[1]: Starting Resilio Sync service...
Apr 25 20:22:47 pocket systemd[1]: resilio-sync.service: Can't open PID file

 

Share this post


Link to post
Share on other sites

I'm also having problems while trying to install resilio sync on my 19.04 ubuntu server.

jussi@athena:~/lataukset$ sudo dpkg -i resilio-sync_2.6.3-1_amd64.deb 
[sudo] password for jussi: 
Selecting previously unselected package resilio-sync.
(Reading database ... 77060 files and directories currently installed.)
Preparing to unpack resilio-sync_2.6.3-1_amd64.deb ...
Unpacking resilio-sync (2.6.3-1) ...
Setting up resilio-sync (2.6.3-1) ...
Job for resilio-sync.service failed because a timeout was exceeded.
See "systemctl status resilio-sync.service" and "journalctl -xe" for details.
invoke-rc.d: initscript resilio-sync, action "start" failed.
● resilio-sync.service - Resilio Sync service
   Loaded: loaded (/lib/systemd/system/resilio-sync.service; enabled; vendor preset: enabled)
   Active: activating (auto-restart) (Result: timeout) since Fri 2019-05-03 19:53:58 UTC; 7ms ago
     Docs: https://help.resilio.com
  Process: 1552 ExecStartPre=/bin/mkdir -p ${SYNC_RUN_DIR} ${SYNC_LIB_DIR} (code=exited, status=0/SUCCESS)
  Process: 1562 ExecStartPre=/bin/chown -R ${SYNC_USER}:${SYNC_GROUP} ${SYNC_RUN_DIR} ${SYNC_LIB_DIR} (code=exited, status=0/SUCCESS)
  Process: 1566 ExecStart=/usr/bin/rslsync --config ${SYNC_CONF_DIR}/config.json (code=exited, status=0/SUCCESS)
dpkg: error processing package resilio-sync (--install):
 installed resilio-sync package post-installation script subprocess returned error exit status 1
Processing triggers for man-db (2.8.5-2) ...
Processing triggers for systemd (240-6ubuntu5) ...
Errors were encountered while processing:
 resilio-sync

Same happens when trying to install from the repo.

Share this post


Link to post
Share on other sites

Please redownload Sync from the following urls & reinstall. Fixed.

http://sync-jenkins-artifacts.s3.amazonaws.com/sync-nas/2.6.3/Debian/resilio-sync_2.6.3-1_amd64.deb
http://sync-jenkins-artifacts.s3.amazonaws.com/sync-nas/2.6.3/Debian/resilio-sync_2.6.3-1_i386.deb

Share this post


Link to post
Share on other sites
1 minute ago, Alex. said:

Please redownload Sync from the following urls & reinstall. Fixed.


http://sync-jenkins-artifacts.s3.amazonaws.com/sync-nas/2.6.3/Debian/resilio-sync_2.6.3-1_amd64.deb

http://sync-jenkins-artifacts.s3.amazonaws.com/sync-nas/2.6.3/Debian/resilio-sync_2.6.3-1_i386.deb

What was the problem?

Share this post


Link to post
Share on other sites
2 minutes ago, Jussi Nirhamo said:

What was the problem?

Path to PID file was set incorrectly in systemd service file.

Previous version of systemd just ignored it. The modern version fails.

We fixed path. Now it works correctly on all systemd versions.

Share this post


Link to post
Share on other sites
Just now, Alex. said:

Path to PID file was set incorrectly in systemd service file.

Previous version of systemd just ignored it. The modern version fails.

We fixed path. Now it works correctly on all systemd versions.

OK, nice job and thanks for the quick fix.

Share this post


Link to post
Share on other sites
17 hours ago, Alex. said:

Please redownload Sync from the following urls & reinstall. Fixed.


http://sync-jenkins-artifacts.s3.amazonaws.com/sync-nas/2.6.3/Debian/resilio-sync_2.6.3-1_amd64.deb

http://sync-jenkins-artifacts.s3.amazonaws.com/sync-nas/2.6.3/Debian/resilio-sync_2.6.3-1_i386.deb

Is this the reason Sync keeps crashing on my 19.04 PC?

Also, any idea when this fix will be added to the repository build?

Share this post


Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.