Sebastian Pająk

Failed to move file to thrash + lots of errors in log

Recommended Posts

I have a lot of troubles setting Resilio to work on my Synology DSM 6.2.

My main problem: Resilio running on Synology cannot remove files from NAS that were deleted from Android peer.

Logs show this (every few minutes):

[20190621 16:54:55.591] Failed to move file /volume1/documents/Android/Home Documents/resiliosync_88f6281_2.6.3-1.spk to trash. Error: 18
[20190621 16:54:55.592] Failed to move file /volume1/documents/Android/Home Wallpapers/resiliosync_88f6281_2.6.3-1.spk to trash. Error: 18
[20190621 16:55:35.647] Failed to move file /volume1/documents/Android/Home Documents/swaks-20181104.0.tar.gz to trash. Error: 18

All ACLs on Synology verified to be R/W for rslsync user. Share is also R/W.

My config is as follows:

{
    "storage_path" : "/usr/local/resiliosync/var",
    "pid_file" : "/usr/local/resiliosync/var/syncapp.pid",
    "display_new_version" : false,
    "use_upnp" : false,
    "listening_port": 64065,
    "vendor" : "synology",
    "webui" :
    {
        "listen" : "[::]:28888",
        "login": "admin",
        "password": "<pass deleted>",
        "allow_empty_password" : false,
        "force_https": true,
        "dir_whitelist": ["/volume1", "/home/admin"]
    },
    "directory_root" : "/",
    "directory_root_policy":"belowroot",
    "sync_trash_ttl": 7
}

 

I have another peer on my PC (Windows 10) connected to the same share.  Deleting files from the PC peer works as expected; file remove is populated to the NAS, and then to the Android. So It works that way, but no the opposite.

Besides this, my logs are full of repeated errors (related?):

[20190621 16:31:33.261] HTTPS: connection [server] has been aborted - code: 336151574, func: "ssl3_read_bytes", reason: "sslv3 alert certificate unknown"

 

Share this post


Link to post
Share on other sites

I've found why Sync cannot remove files: It does not support bind mounted volumes, which I use a lot.. very sad. It should be fixed I guess, or documented somewhere. The app should not crash at least.

The SSL errors are still a mystery for me. Someone can help?

Share this post


Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.