Recommended Posts

Hi,

I am using Resilio Sync on my DS918+ and I am quite satisfied. However, Sync prevents HDD and system hibernation.

I have done the steps described here without success: Sync-prevents-HDD-from-sleeping-on-NAS

When I turn off Sync, hibernation works as expected.

 

Here are a few lines from hibernation.log

[655007.030806] syslog-ng(380): dirtied inode 13424 (.SYNOCONNDB-wal) on md0
[655007.030877] syslog-ng(380): dirtied inode 20126 (.SYNOCONNDB-shm) on md0
[655007.031722] init(1): dirtied inode 13391 (pkg-LogCenter-syslog.log) on md0
[655007.031739] init(1): dirtied inode 13391 (pkg-LogCenter-syslog.log) on md0
[655007.031742] init(1): dirtied inode 13391 (pkg-LogCenter-syslog.log) on md0
[655007.032491] syslog-ng(380): WRITE block 1151224 on md0 (8 sectors)
[655007.037329] ash(10859): dirtied inode 13376 (.bash_history) on md0
[655007.054077] ps(10866): dirtied inode 31481508 (2) on proc
[655007.083522] syslog-ng(380): WRITE block 1151224 on md0 (8 sectors)
[655007.342178] syncd(10757): dirtied inode 3276834 (user-db.sqlite-wal) on dm-1
[655007.343746] syncd(10757): dirtied inode 3276834 (user-db.sqlite-wal) on dm-1
[655007.343753] syncd(10757): dirtied inode 3276834 (user-db.sqlite-wal) on dm-1
[655007.343795] syncd(10757): dirtied inode 3281033 (user-db.sqlite-shm) on dm-1
[655007.343800] syncd(10757): dirtied inode 3281033 (user-db.sqlite-shm) on dm-1
[655009.033186] synologaccd(4951): dirtied inode 26659 (.SYNOACCOUNTDB) on md0
[655009.033422] synologaccd(4951): dirtied inode 25324 (.SYNOACCOUNTDB-wal) on md0
[655009.033460] synologaccd(4951): dirtied inode 25333 (.SYNOACCOUNTDB-shm) on md0
[655009.034154] synologaccd(4951): WRITE block 1202912 on md0 (8 sectors)
[655009.088320] synologaccd(4951): WRITE block 1202912 on md0 (16 sectors)
[655009.113498] synologaccd(4951): dirtied inode 26659 (.SYNOACCOUNTDB) on md0
[655009.113542] synologaccd(4951): dirtied inode 26659 (.SYNOACCOUNTDB) on md0
[655009.113563] synologaccd(4951): WRITE block 791440 on md0 (8 sectors)
[655009.113573] synologaccd(4951): WRITE block 3165416 on md0 (8 sectors)
[655009.125380] synologaccd(4951): WRITE block 1179136 on md0 (64 sectors)
[655012.007824] syslog-ng(351): dirtied inode 30690 (bash_history.log) on md0
[655012.370284] jbd2/dm-1-8(8651): WRITE block 67373520 on dm-1 (8 sectors)
[655012.370322] md2_raid1(8018): WRITE block 8 on sda5 (1 sectors)
[655012.370351] md2_raid1(8018): WRITE block 8 on sdb5 (1 sectors)
[655012.401101] jbd2/dm-1-8(8651): WRITE block 67373528 on dm-1 (8 sectors)
[655012.401116] jbd2/dm-1-8(8651): WRITE block 67373536 on dm-1 (8 sectors)
[655012.401548] jbd2/dm-1-8(8651): WRITE block 67373544 on dm-1 (8 sectors)
[655012.602792] md2_raid1(8018): WRITE block 8 on sda5 (1 sectors)
[655012.602825] md2_raid1(8018): WRITE block 8 on sdb5 (1 sectors)
[655017.540509] jbd2/dm-1-8(8651): WRITE block 67373552 on dm-1 (8 sectors)
[655017.540544] md2_raid1(8018): WRITE block 8 on sda5 (1 sectors)
[655017.540573] md2_raid1(8018): WRITE block 8 on sdb5 (1 sectors)
[655017.575358] jbd2/dm-1-8(8651): WRITE block 67373560 on dm-1 (8 sectors)
[655017.575829] jbd2/dm-1-8(8651): WRITE block 67373568 on dm-1 (8 sectors)
[655017.776950] md2_raid1(8018): WRITE block 8 on sda5 (1 sectors)
[655017.776982] md2_raid1(8018): WRITE block 8 on sdb5 (1 sectors)
[655022.671471] jbd2/dm-1-8(8651): WRITE block 67373576 on dm-1 (8 sectors)
[655022.671507] md2_raid1(8018): WRITE block 8 on sda5 (1 sectors)
[655022.671536] md2_raid1(8018): WRITE block 8 on sdb5 (1 sectors)
[655022.707962] jbd2/dm-1-8(8651): WRITE block 67373584 on dm-1 (8 sectors)
[655022.708416] jbd2/dm-1-8(8651): WRITE block 67373592 on dm-1 (8 sectors)
[655022.910106] md2_raid1(8018): WRITE block 8 on sda5 (1 sectors)
[655022.910140] md2_raid1(8018): WRITE block 8 on sdb5 (1 sectors)
uptime : [655022.910140]
======Idle 22 seconds======
Mon Dec 2 11:28:57 CET 2019

 

I am not sure what to do, other than to look for another alternative. Unless anyone has some ideas?

 

Thanks

 

Link to post
Share on other sites

thanks @Alex.

Actually debug logging was active, as I had some issues with some files not syncing. I deactivated it now and will see if helps. A shame the link that describes setting the intervals does not mention the debug logging.

What about recheck_locked_files_interval, does it also have an influence on hibernation?

 

Link to post
Share on other sites
  • 4 months later...

Why was this situation never resolved in Resilio Sync?

I have the Pro version, but I stopped using it on my Synology NAS after struggling a lot with preventing hibernation. This is a situation that has been going on for years and I don't understand how it may not have been resolved yet!

A NAS is an obvious place to use Sync and hibernation is also an obvious and necessary feature.

I went back to researching this, to see if I would finally install Sync on my NAS again, because I like it a lot, it's the best file sync app I've ever used, but without this problem resolved, it's hard to get back.

Why is Sync not installed on the NAS with the proper settings so as not to prevent hibernation?

Why doesn't Sync still use inotify to be notified of changes to folders?

Edited by zamorim
Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.