Helen

Latest Desktop Build 2.6.4

Recommended Posts

Dear community,

Sync 2.6.4.1344 is hot-fix patched release. Fix included:

Fixed security issue in the Sync WebUI. The credit for reporting this issue goes to Frantisek Uhrecky (fruh)

It's available via "Check now" (manual update) and by direct download links below or from resilio.com site. It was not pushed to autoupdate. contains 

Direct Download Links:

Share this post


Link to post
Share on other sites

I have been using version 2.6.10061 which was previously released (only on the forum, as far as I know) to fix other issues.

Does 2.6.4.1343 include the fixes from 2.6.10061?

If not:

  1. Why not?  2.6.10061 has been around for a long time and we’ve seen no new builds.
  2. What do I do if I need the fixes contained in 2.6.10061 ?

 

Edited by luomat
clarification of release status

Share this post


Link to post
Share on other sites
On 12/24/2019 at 5:47 PM, luomat said:

Does 2.6.4.1343 include the fixes from 2.6.10061?

@luomat No

On 12/24/2019 at 5:47 PM, luomat said:

What do I do if I need the fixes contained in 2.6.10061 ?

Please use the following build

http://internal.resilio.com/support/debug/sync/2.6.10072/Resilio-Sync.dmg

Share this post


Link to post
Share on other sites

Thanks @Alex.

I hope 2020 will see Sync back on track. I appreciate all of the help you’ve given on the forum during the past year which seems like it has been a difficult season behind the scenes.

Share this post


Link to post
Share on other sites

@luomat Thank you!!! ;)

Right now we are working on a new version of Sync with bunch of fixes & great new features.

I can't say exact date, but I'm crossing my fingers and hope it will be soon.

Share this post


Link to post
Share on other sites
11 hours ago, eltopo said:

the url for Android apk is still 2.6.3 (8071), not sure if this was a mistake.

Probably is. Usually all you have to do is manually change the version references in it.

Updated to the latest build across 5 Windows 10 machines with no issues, BTW. Great job, devs.

Share this post


Link to post
Share on other sites

I've installed amd64 version for Linux, from terminal if I digit ./rslsync -v i see the correct version 2.6.4 (1344) but from Web GUI on General Tab I see the version 2.6.3!


Probably is a bug...I've tried in two Linux Machine, same issue.

Share this post


Link to post
Share on other sites

After upgrading to 2.6.4.1344 the webui is no longer working in EDGE and IE (in chrome and firefox it works), the hotfix (2.6.4.1344-1) is even not working in chrome and firefox.

rgds Hans

Share this post


Link to post
Share on other sites

@Alex, which log(s) do you mean?

SYNC-Home is installed on my netgear readynas 212, with upgrade 2.6.4-1344 I can start on my PC the webui (only in firefox and chrome) ; in IE11 & Edge I only get a blank-page, no errors or messages. in the logging of windows I can't find anything.

Share this post


Link to post
Share on other sites

One nice feature on macOS would be a tooltip that shows current speed, as well as maybe progress of any folders currently syncing. It's a few steps to open the app and check each folder.

Share this post


Link to post
Share on other sites

I was getting a blank screen on FF too, then it was stuck forever on the progress bar and "initializing" message. The log told me some rechecks were triggered after the backup and they took some time. So it may be the reason why the blank screen appeared. RPi 3.

Share this post


Link to post
Share on other sites

@Alex,

Here is a part of the logging:

[20200111 12:48:00.045] LF[9AF5]: LicenseFolder::IsActive(consumer): return TRUE, personal license
[20200111 12:48:00.045] LF[9AF5]: LicenseFolder::IsActive(consumer): return TRUE, personal license
[20200111 12:48:07.186] SYS_RES: drive "/", id: 2304, capacity: 3723587584, free_space: 2572640256
[20200111 12:48:07.186] SYS_RES: drive "/data", id: 28, capacity: 2994031362048, free_space: 1359258189824
[20200111 12:48:07.186] SYS_RES: drive "/apps", id: 29, capacity: 2994031362048, free_space: 1359258189824
[20200111 12:48:07.186] SYS_RES: drive "/home", id: 30, capacity: 2994031362048, free_space: 1359258189824
[20200111 12:48:07.186] SYS_RES: drive "/data/Maart", id: 31, capacity: 2994031362048, free_space: 1359258189824
[20200111 12:48:24.945] 21ReverseHTTPConnection::set_error[0xb3550a30][49] 103 (EOF)
[20200111 12:48:24.945] 21ReverseHTTPConnection::set_error[0xb3552030][50] 103 (EOF)
[20200111 12:48:24.945] 21ReverseHTTPConnection::set_error[0xb3562e10][47] 103 (EOF)
[20200111 12:48:25.959] 21ReverseHTTPConnection::set_error[0x0190a4b0][19] 103 (EOF)
[20200111 12:48:35.969] 21ReverseHTTPConnection::set_error[0x018fef90][48] 103 (EOF)
[20200111 12:49:00.225] LF[9AF5]: LicenseFolder::IsActive(consumer): return TRUE, personal license
[20200111 12:49:00.225] LF[9AF5]: LicenseFolder::IsActive(consumer): return TRUE, personal license
[20200111 12:49:07.876] SYS_RES: drive "/", id: 2304, capacity: 3723587584, free_space: 2572640256
[20200111 12:49:07.876] SYS_RES: drive "/data", id: 28, capacity: 2994031362048, free_space: 1359258189824
[20200111 12:49:07.876] SYS_RES: drive "/apps", id: 29, capacity: 2994031362048, free_space: 1359258189824

If I remove statement '        "force_https": true, ' from member SYNC.CONF the webUI is working again in EDGE and IE

of course in HTTP-format and not in HTTPS-format

 

 

 

Share this post


Link to post
Share on other sites
On 1/13/2020 at 9:07 AM, Alex. said:

@Hans# @fink I think self signed SSL certificate will solve your issue.

 

 

@Alex, I tried the self signed SSL certificate, but when I added the 2 statements for the certificate : "ssl_certificate" : "/home/ssl/sync.crt" and "ssl_private_key" : "/home/ssl/sync.key" it results in a non-functional webui.... The web-page is trying the TLS-handshake but ultimate it ends with a time-out, so now also firefox and chrome are failing... So no success yet in getting

Share this post


Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.