Sign in to follow this  
Sebastian Pająk

No connection between 2 computers on LAN

Recommended Posts

I have PC (Windows) and Debian server, both on the same LAN subnet. There is no router and no Internet in this LAN, just switch, and there is no firewall in between. Both IPv4 and IPv6 addresses are working, both machines can see each other (ping, ssh). Both clients are listening on all interfaces. Clients are set correctly because it was working before (different LAN with AP).

But Resilio Sync shows status offline... what am I doing wrong?

Share this post


Link to post
Share on other sites

Resilio Sync discovers other peers through multicast. So I suspect, that in your configuration mutlicast is not working. (or you have multiple NICs and Resilio Sync uses the wrong one)

https://help.resilio.com/hc/en-us/articles/205450205-Peers-aren-t-connecting

 

Nevertheless, because you only have two computers connected, you can specify IP adress of the other machine: Predefined hosts:

https://help.resilio.com/hc/en-us/articles/205458125-Folder-Preferences

Share this post


Link to post
Share on other sites

How to check if multicast is working? I assume it is on by default.`ip a` gives this output:

2: eth0: <BROADCAST,MULTICAST,UP,LOWER_UP> mtu 1500 qdisc mq state UP group default qlen 1000

I don't know how to check it on Windows.

I would rather avoid specifying fixed IP (but I will have to if nothing else works)..

Share this post


Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

Sign in to follow this