Recommended Posts

Hi,

Using resilio-sync 2.6.3. Is there a configuration setting where one can control the owner and permissions of files created by resilio-sync? My android phone is syncing to my NAS and all files are created as "-rw-rw-r-- 1 rslsync rslsync"; e.g. owned by rslsync:rslsync 664. This causes problems for my windows samba client as it's nobody:users so it cannot write these files. How can I change the configuration so that files created by resilio-sync are created as rslsync:users?

Regards,

Link to post
Share on other sites

Maybe is needed to adjust the permissions in the whole. E.g. in my Synologys the Resilio user "rslsync" is member of the admin group. This setting is done from the installation package I can use and works well.

Link to post
Share on other sites
11 hours ago, Andy+ said:

Maybe is needed to adjust the permissions in the whole. E.g. in my Synologys the Resilio user "rslsync" is member of the admin group. This setting is done from the installation package I can use and works well.

That would be good. There is no install options in the Debian package though. Resilio installs and a user and group called rslsync is created. I can make the user a part of other groups but files are still created as rslsync:rslsync I don't see any option to change that. 

A possible solution would be to have the anonymous samba client be rslsync instead of nobody but that feels like a hack. 

Link to post
Share on other sites

Basically, this is not decisive. BTW, on my servers it is the same. It is important that Resilio has unrestricted access as a user or group. In the root directories and the subdirectories. So maybe a membership in the admin is good, I didn't know.

Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.