jdrch

SOLVED: Ubuntu 20.04: Changing "listen" : "127.0.0.1:8888" to "listen" : "0.0.0.0:8888" in /etc/resilio-sync/config.json has no effect on allowing other machines to access web UI

Recommended Posts

I'm running the latest Resilio Sync Home Pro on Ubuntu 20.04. I'd like to be able to access the Web UI from any machine on my network. Currently the setting to disable listening only to 127.0.0.1 is grayed out (see attached image) with the message Connection settings overridden by config, as shown below:

Sync Home Pro HP ProBook 4530s.png

To find out which config file was being used, I opened System Monitor, filtered the Processes tab for rslsync, and then looked at the Command Line column. There I found /

usr/bin/rslsync --config /etc/resilio-sync/config.json

Opening /etc/resilio-sync/config.json reads:

{
    "storage_path" : "/var/lib/resilio-sync/",
    "pid_file" : "/var/run/resilio-sync/sync.pid",

    "webui" :
    {
        "listen" : "127.0.0.1:8888"
    }
}


Question:

How do I enable the listening only setting in the UI via editing the config.json file? Changing

"listen" : "127.0.0.1:8888" 

to

"listen" : "0.0.0.0:8888"

has no effect on the web UI after I restart the Resilio Sync service using

# service resilio-sync restart

If I use

"listen" : "0.0.0.0"

instead and then restart the service, the web UI is no longer accessible at all.

Any ideas?

Share this post


Link to post
Share on other sites

1. Did you verify that rslsync indeed listens to the correct port? 

netstat -anp | grep LISTEN | grep rslsync

2. checked firewall?

I personally use 0.0.0.0:8888 and I can access the WebGUI via any of my interfaces: lo, eth0, nrtap(vpn), zt0(zerotier).

Share this post


Link to post
Share on other sites

Ha, I just realized the message Connection settings overridden by config actually means This state of this setting is not controlled or indicated in the web UI. Using

"listen" : "0.0.0.0:8888"

does in fact enable the web UI's accessibility to other machines on the LAN, it's just that the web UI won't indicate that to you.

I'm now able to access Sync on the Ubuntu 20.04 machine from other machines on the LAN via Ubuntu20.04.IP.Address:8888.

Problem solved!

Share this post


Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.