Recommended Posts

Hi all,

I am running resilio (docker image) on openmediavault v5 on a RPI4 and can access the webui - so all working fine. 

I set up my /sync folder to a volume on a network drive. That the docker code is:

 volumes:
      - /srv/dev-disk-by-label-TESTER/Testing/Resilio/config:/config
      - /srv/dev-disk-by-label-TESTER/Testing/Resilio/downloads:/downloads
      - /srv/dev-disk-by-label-Hippo/Music/TestSync:/sync

I also have resilio app on my android phone and I want to sync the /sync folder (which has music) to my android phone.

the identitities have been setup and are identical on both the server and phone.

When I go the server webui, settings, identity I dont see an option to link my devices like I do with the phone app.

Also, on the server webui, if I click the '+' sign (top left), standard folder, it only allows me to choose the /sync folder but the music within that folder appears missing.

Basically, I cant get the server and phone to link.

Using the free version for now, so not sure if that is the problem?

 

Share this post


Link to post
Share on other sites

With the free version is only possible to use and exchange the key of each peer. For that you can also only use the standard peer type. You choose on server side a folder to set up a peer. After that you share that peer and copy the key and that key you use on your mobile phone to connect.

If you have a license, you can share on your server the identity of your mobile phone and if that connected you will find a list of peers of each others are connected to that identity.

Share this post


Link to post
Share on other sites

Thanks Andy+ but really sorry as a newbie so still not quite following. 

My /sync folder is setup as a volume:

- /srv/dev-disk-by-label-Hippo/Music/TestSync:/sync

So within this drive folder /TestSync I have some music.

On Resilio WebUI, I've clicked on the "+" sign and choose Standard Folder. A new dialog box opens headed "Choose Folder". The only folder I can choose for me anyway is "/sync".

I then clicked Open but nothing happens.

Or am I doing it completely wrong?

Share this post


Link to post
Share on other sites

Left side of above sequence is your folder on your server, after the ":" is /sync and this folder is inside of your container. For additional folder you read

https://hub.docker.com/r/resilio/sync

about "Extra directories".

Instead of that is possible to use the sequence /srv:/sync and you make from here your subfolders

/dev-disk-by-label-Hippo

/dev-disk-by-label-Hippo/Music

/dev-disk-by-label-Hippo/Music/TestSync

and maybe

/dev-disk-by-label-Hippo/TestSync2

So you have in your container also all that folders, which you can see also in the GUI.

Share this post


Link to post
Share on other sites

I'm using using the linuxserver image as I could not even get the resilio sync docker image to work. But tried to add an extra directory but no change but that is probably because I am using different image,

 

Share this post


Link to post
Share on other sites

Regarding a "normal" linux server image I have no experience, since I use on all my Synology´s a installation package, which make all basic settings. So maybe also the mounting of volumes and so one, I dont know. Maybe you find in the internet some instructions for that, such as

https://help.resilio.com/hc/en-us/articles/206178924-Installing-Sync-package-on-Linux

and other direct download links

 

Share this post


Link to post
Share on other sites

I have just played around with the volume and changed it to:

/dev-disk-by-label-Hippo/Music

And now I can see the TestSync subfolder when I click add on the GUI but I have another question.

Under the volume  /dev-disk-by-label-Hippo/Music, I actually have three subfolders: Music, Master and TestSync.

Do you know why I am only seeing TestSync as I would have thought all three subfolders should be showing?

Share this post


Link to post
Share on other sites

Maybe is a thing of permissions. The user of Resilio calls normally "rslsync", what I know. If rslsync is member of administrator group, normally you see that folders. Otherwise you give rslsync all the needed permissions.

Share this post


Link to post
Share on other sites

ok wil lhave to check that.

but i may have been premature that the issue is sorted. although I can now see TestSync on the WebUI and there are files there on the NAS, the WebUi is saying the folder is empty.

Share this post


Link to post
Share on other sites

It could be different issues. Resilio must indexing all content, normally you see such activities in the GUI. By right click with mouse to the coloumn line you can switch on different coloumns, among others the number of files etc. This must increase up to the current number of files. If you have no permission message and maybe a red exclamation mark beside, I think this is not the problem.

Share this post


Link to post
Share on other sites
 

Ok have added extra columns to see what is happening and now I am utterly confused.

Although my volume has changed to:

/srv/dev-disk-by-label-Hippo/Music:/sync

And on the WebUI, I can get to /TestSync which is a subfolder of my network drive above.

On the webui, the path is showing as /sync/Music/TestSync

I am using openmediavault v5.

Share this post


Link to post
Share on other sites

So I have understood you have on Resilio side

/sync/Music/Music

/sync/Music/Master

/sync/Music/TestSync

so on server side you have

/srv/dev-disk-by-label-Hippo/Music/Music/Music

/srv/dev-disk-by-label-Hippo/Music/Music/Master

/srv/dev-disk-by-label-Hippo/Music/Music/TestSync

That is what I see with the sequence

/srv/dev-disk-by-label-Hippo/Music:/sync

Share this post


Link to post
Share on other sites
2 minutes ago, Andy+ said:

with which NAS, it means hardware?


 

Sorry I am testing Resilio on a RPI4.

On Resilio side, I see:

/sync/Music/Master

/sync/Music/TestSync

On server side, I have:

 

/srv/dev-disk-by-label-Hippo/Music/Music

/srv/dev-disk-by-label-Hippo/Music/Master

/srv/dev-disk-by-label-Hippo/Music/TestSync

With the volume setup now, I have:

/srv/dev-disk-by-label-Hippo:/sync

 

Share this post


Link to post
Share on other sites
6 minutes ago, tannaroo said:

Resilio on a RPI4

Its maybe a challenge for RPI because of resources Resilio needs, if you have a lot of files and folders. But at first that needs some tests by you.

Share this post


Link to post
Share on other sites

There is very few files for now, only about 20. I am testing Resilio on RPi4 to get it working and to understand it, Then I will move it over to my main openmediavault server running on a Dell i5.

Share this post


Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.